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Excel Exercise 1: Excel Data Cleaning 

Summary: Microsoft Excel can be used to perform data cleaning procedures.  Data 
cleaning is essential before using the data for mapping and analysis.  Often, what 
looks best in reports and on paper is not the best for data verification, analysis, or 
maps.  We will clean an example data file using a variety of Excel tools and 
formulas.   

Objectives:  

• Format data into a standard Excel table. 
• Learn how to use basic Excel functions, e.g. Text to Columns, Find and 

Replace  
• Learn how to use basic Excel formulas, e.g. TRIM, CLEAN, LEFT, RIGHT, 

CONCATENATE  
• Learn how to filter and sort data in Excel.   

 

Section 1: Open, explore, format, and save 

We will open the Excel workbook to examine likely issues.  Remove extraneous rows 
and columns.  Adjust the column names so that each column has only one cell in 
row 1 which will serve as the column name.  Save the file with a new name.   

1. Copy the Training_Workshop folder from the USB flash drive to your desktop 
 

2. From your desktop, open the Excel file 
\\ Training_Workshop\05_Data\01_Excel\MEASURE_surveys.xlsx 
 
3. Save a copy by clicking File and Save As or clicking the Office Button (the 

round button in the upper left corner) and selecting Save As.  Save the file to 
\\Training_Workshop\06_Participant_Work and name the file 
MEASURE_Surveys_Cleaned.  

 
4. Delete Rows 1-3 and Column A by right clicking in the row number and 

column header and selecting Delete. 
 
5. Select row 1 by left clicking in the row number and highlighting the row.   
 
6. Click the arrow next to Merge and Center in the Home menu.  Select 

Unmerge Cells from the drop down list. 
 
7. Move the cells H2, I2, and J2 (SurveyData, GPSData, Biomarkers) from Row 

2 to Row 1. 
 
8. Click OK to replace the contents of the destination cells. 
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9. Delete Row 2.  Each column should have one cell in Row 1 with the column 

name.   

NOTE: Clean data consists of one row per record and a single column name.  
Extra rows and columns create problems for sorting, filtering, and pivoting.  
These tables may look nice when printed or viewed by a human but a 
computer will not understand data in this format.   

10. Click Save. 
 

Section 2: Convert text to columns 

The Text to Columns tool can split one column into several using a delimiter, i.e. 
comma, semicolon, tab, etc.  This tool will also store the data with the proper format.  
For example, numbers stored as text will be converted to numbers.  In this example, 
the country name and year(s) of the survey are stored in one column (Country/Year) 
and years are numbers stored as text.  Numbers stored as text will restrict the ability 
to sort and filter properly but will not affect mathematical formulas.   

1. Insert a new column to the right of column A by right clicking on the column 
heading of Type (Column B) and selecting Insert. 

 
2. Select the entire Country/Year column by left clicking the header.   
 
3. Click the Text to Columns tool in the Data Ribbon Tab. 
 
4. Select Delimited in the first window in the Convert Text to Columns Wizard. 
 
5. Click Next. 
 
6. Check Comma and uncheck Tab in the Delimeter window. 
 
7. Click Next. 
 
8. Select General under Column data format in the third window. 
 
9. Click Finish. 
 
10. If you receive a warning "Do you want to replace the contents of the 

destination cells?" click Ok.   
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11. Enter new column names – "Country" for Column A and "Year" for Column B. 

NOTE: Text to Columns can also convert data stored in one format into 
another format.  For example, numbers could be stored as text.  Examine 
Columns C and D (Type and CC/SurveyCode.  You may see the green arrow 
in the upper left corner of each cell.  Clicking on one of these green arrows 
should give you a warning message of "Number Stored as Text".   

12. Click Save.   
 
 

Section 3: LEFT and RIGHT Formulas 

Sometimes one column will contain multiple pieces of information.  For the purposes 
of sorting or filtering, you may need these pieces of data in separate, distinct 
columns.  The LEFT and RIGHT formulas allow you to extract these data 
systematically.  In this example, the survey code is combined with the year of the 
survey.  You will separate the information and create a new column for the survey 
code.   

1. Insert a new blank column by right clicking on CC/SurveyCode (Column D) 
and selecting Insert. 

 
2. In D2 type the formula =RIGHT(E2,3) 

NOTE:   Within the parentheses, the first variable specifies the cell that will 
be shortened.  The second variable is the number of characters from the 
right.  In this case, we are extracting the first three characters starting on the 
right from CC/SurveyCode.  These three characters make up the Survey 
Code. 

3. Fill this formula down the entire column either by dragging the bottom right 
corner of D2 or double clicking on the bottom right corner once the cursor 
becomes a black cross.   

 
4. Name Column D SurveyCode. 
 
5. Delete the entire CC/SurveyCode column. 

NOTE:   What happened?  You should see a "#REF!" error in the new 
column.  This is because the formula was referencing the column you 
deleted.  To fix this, you must copy and paste the formula results using Paste 
Special. 
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6. Click Undo or press ctrl+z.  The CC/SurveyCode column should now reappear. 
 
7. Right click in the column D heading and select Copy.   
 
8. Right click on the column D heading and select Paste Special.   
 
9. Select Values to paste the results of the formula and click OK.   
 
10. Insert a new column to the left of CC/SurveyCode. 
 
11. In E2 type the formula =LEFT(F2,2) 

NOTE:   Within the parentheses, the first variable specifies the cell that will 
be shortened.  The second variable is the number of characters from the left.  
In this case, we are extracting the two characters starting on the left from 
CC/SurveyCode.  These two characters make up the Country Code. 

12. Fill this formula down the entire column either by dragging the bottom right 
corner of E2 or double clicking on the bottom right corner once the cursor 
becomes a black cross.   

 
13. Right click in the new column heading and select Copy.   
 
14. In the same column, right click on the column heading and select Paste 

Special.   
 
15. Select Values to paste the results of the formula and click OK.   
 
16. Enter a name for this new column in E1 as CtryCode. 
 
17. Delete the CC/SurveyCode column. 
 
18. Click Save. 

 

Section 4: Find and Replace 

Spreadsheets often contain data that are not necessary.  An easy way to remove 
extraneous information is through find and replace.  In this example, we will remove 
the suffix "Survey" from the Status column. 

1. Left click on the Status column header to select the entire column.  
 
2. Click on the Find and Select button in the Home menu and select Replace... 
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3. Enter Survey in the Find what: box.  
  
4. Leave the Replace with: box blank and click Replace All. 

NOTE:   By leaving the replace with box empty we are essentially deleting 
the word Survey from the column as well as the trailing space.   

5. Close the Find and Replace window and examine the Status column now.  
What do you see? 

 
6. Click Save. 
 
 

Section 5: CLEAN and TRIM Formulas 

If data is copied from another source, like Word, there could be special, non-
printable characters like bullets (•).  The CLEAN formula removes these characters 
leaving only printable characters.  Trailing, leading or extra spaces cause problems 
when sorting data or when matching on an entire cell's content.  The TRIM formula 
removes these spaces leaving a single space between words.   

1. Insert a new, blank column to the right of Type. 
 
2. In D2 type the formula =CLEAN(C2). 
 
3. Fill this formula down the entire column either by dragging the bottom right 

corner of D2 or double clicking on the bottom right corner once the cursor 
becomes a black cross.   

NOTE:   If there are extra spaces, they will remain.  The TRIM formula will 
remove them.   

4. Right click in the D column heading and select Copy.   
 
5. In the same column, right click on the column heading and select Paste 

Special.   
 
6. Select Values to paste the results of the formula.   
 
7. Delete the Type column. 
 
8. Enter Type as the name for the new column in C1. 
 
9. Insert a new, blank column to the right of Column A. 
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10. In B2 type the formula =TRIM(A2) 
 
11. Fill this formula down the entire column either by dragging the bottom right 

corner of B2 or double clicking on the bottom right corner once the cursor 
becomes a black cross.   

 
12. Right click in the new column heading and select Copy.   
 
13. In the same column, right click on the column heading and select Paste 

Special.   
 
14. Select Values to paste the results of the formula.   
 
15. Now, rename Column B as Country and delete column A. 
 
16. Click Save.   
 
 

Section 6: Concatenate Using Ampersand (&) 

We can create a unique survey ID by combining Country Code, Survey Code, and 
Year using the ampersand (&) in a formula.  The formula = CONCATENATE serves 
a similar function but each cell reference is separated with a comma (,) instead of the 
ampersand (&).   

1. Insert a new, blank column to the right of CtryCode. 
 
2. In F2 type the formula =E2&"-"&D2&"-"&B2 

NOTE:   The ampersand (&) separates cell references that will be combined 
in the new cell.  Insert text by using quotes (") before and after the text.  In 
this example we are combining cells E2, D2, and B2 and inserting a dash (-) 
between each.   

3. Fill this formula down the entire column either by dragging the bottom right 
corner of F2 or double clicking on the bottom right corner once the cursor 
becomes a black cross.  

  
4. Name the new column SurveyID. 
 
5. Click Save. 
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Section 7: Comparing Using Formulas 

Comparing data within your file is a useful way to examine the quality of the data.  
For example, the newly created SurveyID should match the RecordID from the 
original data.  If they don't match, this could indicate a problem with the data or with 
our data cleaning process.  The formula =[CELL REFERENCE 1]=[CELL 
REFERENCE 2] checks for an exact match between two difference cells.   

1. Insert a new, blank column to the right of RecordID. 
 
2. In K2, type =F2=J2. 
 
3. Fill this formula down the entire column either by dragging the bottom right 

corner of R2 or double clicking on the bottom right corner once the cursor 
becomes a black cross.   

 
4. Name the new column "RecordID Match". 
 
5. Look down RecordID Match.  Do they all display TRUE?  Can you spot the 

difference? 

NOTE:   There is a space in front of the Country Code for the BU-DHS-2010 
RecordID.   

6. Select the Burundi BU-DHS-2010 Record ID cell and delete the extra space 
in front of the country code. 

 
7. The text in the corresponding RecordID Match column should change to 

TRUE once the additional space has been deleted. 
 
8. Delete the columns RecordID and RecordID Match. 
 
9. Click Save. 
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Section 8: Filter and Sort 

Once the obvious errors have been cleaned, we can begin to dig deeper and 
examine the internal consistencies of the data.  This will help us spot other errors 
that may not be visible on the first look.  For this, we will use the filter and sort 
functions.  The data must be properly formatted for these functions to produce 
usable results.   

1. Select Columns A-L by left clicking Column A's header and while holding the 
mouse buttons, select to the right until you get to Column L.   

 
2. Click Filter in the Data Menu. 

NOTE:   You can also click the Filter icon on the Home ribbon in Excel 2007 
or press ctrl+shift+L.   

3. Try to sort Fieldwork column from smallest to largest by clicking on the grey 
down arrow in the column name and select the option "Sort Smallest to 
Largest."  What happened? 

NOTE:   This option is not available (the only available options are sort A to Z 
or sort Z to A) because these numbers are stored as text.  This is why we 
used Text to Columns to change the Year column from text to numbers.   

4. Sort the Country column from A to Z by clicking on the grey down arrow in 
the column name and select the first option Sort A to Z.   

 
Now all of the surveys are sorted alphabetically by country. Next you will filter the 
SurveyCode column to check the codes against the Type column.   

 
5. Click on the grey down arrow in the SurveyCode column name. 
 
6.  Uncheck the Select All box. 
 
7. All of the boxes should now be unchecked.  Click on the box next to DHS to 

recheck it. 
 
8. Click OK. 
 
9. Now you should only see different types of DHS surveys. Click on the grey down 

arrow in the Type column to verify that all of the records are a type of DHS 
survey. Do you notice anything wrong? 
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You should see all DHS survey types, but the last entry on the list is misspelled. 
 

  
 
10. Uncheck the Select All box. 
 
11. Recheck the misspelled Standard DSH box. 
 
12. Click OK. 
 
13. Correct the spelling of this record to Standard DHS. 
 
14. Click the Clear button in the Sort & Filter section of the Data tab to clear the 

filters and show all of the survey records. 
 
15. Click Save. 

 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Excel Exercise 2: Excel Pivot Tables 

A pivot table is one way to summarize data.  It allows us to add together data for 
similar groups.  For example, you may have survey data but you would like to see 
the country totals.  Similarly, you may have multiple rows per survey code but you 
would like to see the data at the code level.  In this example we will aggregate 
survey records for each country.   

Objectives:  

• Construct a pivot table with the MEASURE survey data 
• Create summary tables of these data by a variety of categories 

Section 1: Create a Basic Pivot Table 

We are using the data we cleaned in the previous exercise. 

1. Open the Excel file 
\\Training_Workshop\06_Participant_Work\MEASURE_Surveys_Cleaned.xls 

 
2. Select the data by clicking on the upper left, un-numbered, un-lettered 

square. 
 

 
 
3. Select PivotTable in the Insert menu.   
 
4. Choose to place the PivotTable in a New Worksheet.   

NOTE: This will create a new tab with the Pivot Table.  The table will 
reference data in the original worksheet so that any changes to the original 
data will be reflected in the Pivot Table.  If the table was already calculated, 
you will have to click Refresh in the PivotTable Tools, Data menu or press 
Alt+F5.     

5. Click OK. 
 
The view will automatically switch to the new sheet with the pivot table.  On the right 
side of the page will be the PivotTable Field List that will allow you to customize your 
pivot table. 
 

6. In the PivotTable Field List, click and drag the Country field to the Row 
Labels box. 
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7. Drag the SurveyCode field to the Values box.   

NOTE: You should see a table like this.  Notice that the data are aggregated 
as a sum.  There are other options but this seems to be best choice for these 
data.   

    

  

Section 2: Create an Advanced Pivot Table 

Continue with the same data and create more complex tables. 

1. Drag the SurveyCode field to the Column Labels box.   

NOTE: You should see a table like this.  Each row is one country and each 
column is one survey code. 
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2. Drag the field Year to the Row Labels.  Be sure to place the field below 
Country in the Row Labels box.   

NOTE: You should see a table like this.  Now each survey is grouped by 
country in the rows and the survey code is displayed in each cell by year. 
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Section 3: Change the Data Aggregation 

Now you will change the aggregation and the view of the data by switching the 
columns and other boxes. Continue with the same data to explore the options for 
Pivot Tables. 

1. Remove all the fields from the PivotTable by un-checking the box next to 
their name in the "Choose fields to add to report: box".   

 
2. Drag the Status field to the Column Labels box.   
 
3. Drag the field SurveyCode to the Row Labels box. 
 
4. Drag the field SurveyCode to the Values box. 
 

NOTE: You should see a table like this.  Each row is one survey category 
and the columns are the counts for the number of ongoing and completed 
surveys within each survey category. 
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5. Add the Country field to the Row Labels box.  Make sure that the 
SurveyCode field is above the Country field. 

 
NOTE: The table now lists the countries in which each survey category have 
been conducted, and the column labels indicate whether the surveys have 
been completed or are still ongoing. 

   
 
6. Save a new version of the file by clicking Save As…  
 
7. Name the file MEASURE_Surveys_Pivot and save it in 

\\Training_Workshop\06_Participant_Work. 
 
8. Close Excel. 

 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government.
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Excel Exercise 3: Excel Crosswalk Tables 
 
Summary:  Crosswalk tables are used to bring together different data files that have 
data at the same level of aggregation (for example country) but do not use the same 
numeric codes or the same spelling. 
 
Objectives: 

• Explore your data file to make crosswalk table. 
• Use the Excel VLOOKUP formula to match files 
• Check your match  
• Prepare a final crosswalk table 

 

Section 1: Explore data file 

In this step we will explore the data file that was prepared for this exercise. 
 

1. Open the Excel file 
\\Training_Workshop\05_Data\01_Excel\Country_Match.xlsx 
 

2. Look at the data in each worksheet “GIS_data,” “Survey_Totals,” and 
“CountryCodes” 

 
a. What kind of data is in each worksheet? 
b. Do the country codes in each worksheet match those in the other 

worksheets? 
 

3. Click Save As… and save the file to 
\\Training_Workshop\06_Participant_Work naming it Country_match_2012. 
 
NOTE: We save the file before working on it so that in case we have any 
problems we can always return to the original data. 
 
NOTE: For this exercise we are considering the “GIS_data” worksheet as the 
CORRECT codes for these data. 

 
 

Section 2:  Use VLOOKUP to match data 

VLOOKUP is used to connect two worksheets within the same workbook. 
 

1. Open the “Survey_Totals” worksheet by clicking the tab. 
 

 
2. Insert a new column to the right of the Country column. 

 
3. In B1, enter DHS_CC. 

 
4. In cell B2, enter =VLOOKUP(A2,CountryCodes!A:F,3,FALSE) 
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5. Hit ENTER on your keyboard. 
 

NOTE:  VLOOKUP default format is  
=VLOOKUP(lookup_value, table array, col_index_num, [range_look_up] 

• Lookup_value is the cell reference that contains the information you 
are looking up. 

• Table array is the place where the information you are matching to is 
located, make sure the first column of the table array is the 
“lookup_value” 

• col_index_num is the column number (starting with the 
lookup_value/first column) that you want returned to your table 

• range_look_up, enter FALSE or 0 to indicate that you want the match 
to be made exactly letter for letter/number for number 

 
6. Click B2, then move the mouse to the bottom right corner, when the mouse 

changes to a small “+” double click. 
 

NOTE: This will fill in the formula down to the bottom of your table (as long 
there are no cells to the immediate left that contain no data). 

 
7. Scroll through your table.  Look at the column with the match information. 

• Does this look correct? 
• Are there any countries where the lookup value is “#N/A”? 

 
8. Select the first row of the worksheet by left-clicking on the number 1. 
 
9. Click the filter button in the Data tab. 

 
10.  Click on the grey arrow in the DHS_CC column and uncheck Select All, and  

then recheck #N/A. 
 

This filters the results and shows there are 6 countries that did not match. 
 

 
 

11. Examine the “#N/A” rows that did not match.  
 
12. Look at cell A23 (Cote d’Ivoire) in the Survey_Totals worksheet, and then 

look at cell A42 (Côte d'Ivoire) in the CountryCodes worksheet. 
 

NOTE:  This is an example of why making a match on a name is difficult, 
since slight difference in spelling, accents, or spaces can make the match 
invalid. 
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13.  Find the name equivalent in the CountryCodes sheet for each non-matched 
country and copy the DHS_CC for that country and insert it into the DHS_CC 
column in the Survey_Totals sheet.  

 
NOTE:  Your results should look like this. 

 

 
 
14. Clear your filters by clicking on the Filter button in the Data tab. 
 
15. In the “Survey_Totals” worksheet, copy the “DHS_CC” column. 
 
16. Right click B1, select “Paste Special”. 
 
17. Select “Values", then OK. (See example below). 
 

  
 

NOTE: Using Paste Special “Values” for a VLOOKUP column removes the 
VLOOKUP formula and keeps only the results. 

 
 

Section 3:  Use VLOOKUP to see other table information  

In Section 2 you made the link by DHS country code between the Survey_Totals and 
CountryCodes, data.  Now we will add the GIS_data country code to the 
Survey_Totals file by linking on the DHS country code. 
 

1. In the Survey_Totals sheet, insert a column to the right of DHS_CC 
 

2. In the Survey_Totals sheet, enter CC in C1 
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3. In cell C2, enter =VLOOKUP(B2,GIS_data!A:D,2,FALSE) 
 

NOTE: This is similar to the code we entered in Section 2.  However, the 
function will return data from the GIS_data worksheet instead of the 
CountryCodes worksheet.  
 

4. Click C2, then move the mouse to the bottom right corner, when the mouse 
changes to a small “+” double click or click and drag down to the bottom of the 
table. 
 

5. Examine the CC column.  All of the countries should have properly matched. 
 

6. Copy the CC column. 
 

7. Click C1, right click and "Paste Special" selecting "Values". 
 

 
Optional Steps 
 

1. Add the FIPS_CC code from the CountryCodes worksheet to the 
Survey_Totals worksheet. 
 

2. Add the GIS_data Region information to the Survey_Totals worksheet. 
 

 
 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 0:  Installing QGIS & Plugins 

In this exercise you will learn how to install QGIS and add plugins to expand the 
functionality of the software.  The instructions will vary depending on your operating 
system.   
 
 

Section 1:  Download and Install QGIS 

If you are using Windows Vista or Windows 7, you will need to right click and select 
Run as Administrator.  If you do not use this method, the software will install but 
not run correctly.  If you are using an older version of Windows XP and do not have 
the C++ Runtime Engine, the software will not operate correctly.  Download the 
latest package and install this prior to installing QGIS.  If you have an earlier version 
of QGIS installed on your computer, you will need to uninstall it.   
 
 

1. Open the Training_Workshop folder. 
 

2. Install QGIS using the QGIS-OSGeo4W-1.8.0-1-Setup.exe file. 
 
OR 
 

1. Use a web browser and navigate to http://www.qgis.org.  
 

2. Click download and select the current version.  For Windows users, choose 1 
Windows - 1.1 Standalone Installer (recommended for new users) 
 
NOTE:  Since this is open-source software, changes are constantly being 
made to the code.  This manual was created using version 1.8.0 Lisboa.  
Icons and menus may be different in other versions.     

 
3. Once the download is complete, install using the *.exe file. 

 
 

Section 2:  Install Plugins Off-line 

Plugins add functionality to the basic installation of QGIS.  These tools are written by 
members of the open source community.  Some are highly complex while others are 
basic, meant to accomplish one specific task.  You can install as many or as few as 
needed.  You can download the Plugins online via the “Fetch Python Plugins” option 
(See Appendix) or you can install them from the training folder.   

1. We have pre-downloaded several commonly used plugins which you can 
install off-line.  Open the 07_Plugins folder in the Training Folder.  In a 
separate window, browse to the .qgis folder located at 
C:\Users\YourUserName\.qgis. 

   

http://www.qgis.org/�
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2. Copy the python folder from the Training_Workshop/07_Plugins folder to the 
.qgis folder.    

 
NOTE: If you have installed plugins, this will replace them.  
 

   
 
Let’s open QGIS and look at the plugins we’ve installed. 

3. If you have a shortcut for QGIS        on your desktop, double click it to 
start QGIS. Otherwise, click Start > Programs > Quantum GIS Lisboa > 
Quantum GIS Desktop(1.8.0). 

 
NOTE: Make sure that you open Quantum GIS Desktop, not the similarly 
titled Quantum GIS Browser. 

 
4. Click Plugin > Fetch Python Plugins…  
 

 
 

NOTE: You must be connected to a stable internet connection to download 
more plugins.   
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5. The QGIS Python Plugin Installer window will appear. Your window may show 
fewer plugins than the image below.  Read through the descriptions of the 
plugins which are installed. 

 

 
 
6. You should have the following plugins:  

 
• 1-Band Raster Colour Table V1.x1

• EasyPrint 
 

• Metatools 
• Point sampling tool 
• Statist 
• ZonalStats 
• Open Layers Plugin 
• AutoSave 
• fTools. 

 
7. Click the Options tab. 

 
8. Select the radio button next to Show all plugins except those marked as 

experimental. 
 
NOTE: The standard default repository is the ‘official QGIS’ server.  Changing 
the default option will allow you to view and install additional plugins from 
different sources. 

 

                                                           
1 From the bcccoltbl1 tools plugin folder 
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9. If you have an internet connection, you can use the Repository tab to add 
additional sources of plugins.  See the appendix for detailed instructions.  
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10. Click Close. 

 
11. Restart QGIS Desktop. 

 
 

Section 3:  Add Plugins 

 
1. Click Plugins > Manage Plugins… 
 

 
 
 

2. Within this dialog box you can add the installed plugins to QGIS. 
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3. Select the check box next to the following plugins: 
• 1-Band Raster Colour Table V1.x 
• Add Delimited Text Layer 
• Easy Print 
• GPS Tools 
• Metatools 
• Open Layers Plugin 
• Point Sampling Tool 
• Statist 
• ZonalStats 
• fTools plugins 
• Any additional plugins you wish to add and click OK.  

 
4. You should now see several plugins as buttons on the Plugins Toolbar at the 

bottom left of the screen.  These plugins may also be found in the Plugins 

menu.  
 

NOTE:  Your Plugin Toolbar buttons will vary depending on which are 
installed.  Hover with the mouse over each button to display the text 
description.  If you experience problems after installing a plugin, uninstall it.  
 
NOTE:  Some of the Plugins add themselves under other toolbars:  For 
example, Statist shows up on the Vector toolbar   and 
ZonalStats shows up on the Raster toolbar  

 
 

Exercise End 

MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Appendix 0:  Install Plugins online 

Plugins add functionality to the basic installation of QGIS.  These tools are written by 
members of the open source community.  Some are highly complex while others are 
basic, meant to accomplish one specific task.  You can install as many or as few as 
needed.   

1. If you have a shortcut for QGIS        on your desktop, double click it to 
start QGIS. Otherwise, click Start > Programs > Quantum GIS Lisboa > 
Quantum GIS Desktop(1.8.0). 

 
NOTE: Make sure that you open Quantum GIS Desktop, not the 
similarly titled Quantum GIS Browser. 

 
2. Click Plugin > Fetch Python Plugins…  
 

 
 

NOTE: You must be connected to a stable internet connection.  The 
plugins are installed through the web. 

 
3. The QGIS Python Plugin Installer window will appear once the connection to 

the internet is verified. Your window may show less plugins than the image 
below. 
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4. Click the Options tab. 

 
5. Select the radio button next to Show all plugins except those marked as 

experimental. 
 
NOTE: The standard default repository is the ‘official QGIS’ server.  Changing 
the default option will allow you to view and install additional plugins from 
different sources. 
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6. Click the Repository tab to view or add additional sources of plugins. 
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NOTE: If you know the URL of a specific repository not listed you can add it 
using the Add… button and entering the name and URL from the above 
image.  URLs to some repositories are provided in the PluginsTracker.xls file 
 

NOTE: Click the Add  button if you do not see the Sourcepole 
Repository listed. 
1. Enter Sourcepole Repository for the Name. 
2. Enter http://build.sourcepole.ch/qgis/plugins.xml for the URL. 
3. Make sure the box next to Enabled is checked. 
4. Click OK. 

 
7. Click the Plugins tab. 
 
8. Read through the Description and select the plugins you wish to install by 

clicking it.  Selected plugins will appear bold.   
 
9. To install a specific plugin, select the plugin and click Install plugin. 
 

 
 
10. To uninstall a plugin, select the plugin and click Uninstall plugin. 
 

 
  
11. Install at least the following plugins:  

 
• 1-Band Raster Colour Table V1.x 
• EasyPrint 
• Metatools 
• Point sampling tool 
• Statist 
• ZonalStats 
• Open Layers Plugin 

 
12. Click Close. 
 
13. Restart QGIS Desktop. 
 
14. Click Plugin > Fetch Python Plugins…  
 
15. In the Python Plugin Installer window, verify that the plugins you just installed 

say installed under the Status section. 
 
16. Return to Section 3 in the Plugins Exercise to Add in the plugins you have 

installed. 

 

http://build.sourcepole.ch/qgis/plugins.xml�
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Appendix 1:  Download and Install QGIS in Mac OSX 

The install files provided were designed the Lion or Snow Leopard OS. 

1. The training Dropbox/CD/MacOS contains QGIS 1.8.0-2 installation files – 
QGIS-1.8.0-2.dmg 
 

2. Copy the training folder to your computer and open the dmg file.   
 

3. Install QGIS. 
OR 

1. Use a web browser and navigate to http://www.qgis.org.  
 

2. Click download and select the current version.  For Mac users, choose 3.1 
Release.  This will require you to go to the KyngChaos Qgis download page.2

  
 

NOTE:  Since this is open-source software, changes are constantly being 
made to the code.  This manual was created using version 1.8.0 Lisboa.  
Icons and menus may be different in other versions.     

 
3. Once the download is complete, install. 

 
The Mac OSX version of QGIS requires the installation of several additional 
components in order to run properly.  Currently, the required components include:  

• GDAL Complete 1.9 framework package3

• 
 

GSL framework4

Two optional components include:  

 

• GRASS 6.4.25

• 
 

Python Modules for plugins 

The installation files for these can also be found in the CD/MacOS folder, or on 
the KyngChaos Qgis download page.The GRASS application should be installed 
after the GDAL and GSL frameworks.   

Specific python modules may be required for plug-ins to work properly.  We suggest 
installing the pysal and scipy python modules.  Plug-ins provide extra functionality 
and some advanced analysis tools. 

Instructions on installing plugins while off-line can be found in the QGIS Exercise:0 
Installing QGIS and Plugins instructions, while those for installing plugins while 
online can be found in the Appendix:  Install Plugins online. 

                                                           
2 http://www.kyngchaos.com/software/qgis 
3 http://www.kyngchaos.com/files/software/frameworks/GDAL_Complete-1.9.dmg 
4 http://www.kyngchaos.com/files/software/frameworks/GSL_Framework-1.15-2.dmg 
5 http://www.kyngchaos.com/files/software/grass/GRASS-6.4.2-5-Snow.dmg 

http://www.qgis.org/�
http://www.kyngchaos.com/software/qgis�
http://www.kyngchaos.com/software/frameworks#gdal_complete�
http://www.kyngchaos.com/software/frameworks#gsl�
http://www.kyngchaos.com/software/grass�
http://www.kyngchaos.com/software/python�
http://www.kyngchaos.com/software/qgis�
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QGIS Exercise 1:  Exploring QGIS 
 
This exercise will introduce you to QGIS and some of the basic functions of the 
program.  By the end of this exercise you should be able to: 
 

• Open a current QGIS file 
• Set up the layout of your QGIS file 
• Zoom, move, and navigate a map  
• Turn layers on and off 

 
 

Section 1:  Start QGIS 

1. If you have a shortcut for QGIS        on your desktop, double click it to 
start QGIS. Otherwise, click Start > Programs > Quantum GIS Lisboa > 
Quantum GIS Desktop(1.8.0). 

 
NOTE: Make sure that you open Quantum GIS Desktop, not the similarly 
titled Quantum GIS Browser. 

 
You are now looking at the interface of the QGIS application.  
 
Whenever you work in QGIS Desktop, you are working with a map document. This 
document can contain various layers, which are populated by spatial datasets. A 
QGIS map document has a *.qgs file extension. 
 
 

Section 2:  Open a .qgs file 

A map document was created for this exercise. You will use this file to examine 
some of the features of QGIS. 
 

1. Click File > Open Project… 
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2. Navigate to the \\Training _Workshop\04_Exercises\Project_files folder and 
locate Exploring_QGIS.qgs 

 
3. Double click Exploring_QGIS.qgs to open and display the map. 

  
When the Exploring_QGIS.qgs opens, you will see an image depicting Africa with 
the location of various countries.  It should look similar to the image below.  
 

NOTE: Your screen might show this in a different size and with the toolbars in 
different locations.  If you are using a different version of QGIS, you might see 
a warning about project compatibility. 
 

 
 
 

Section 3:  Setting up your QGIS layout 

The next image shows the individual pieces of the user interface in QGIS.  Your 
QGIS window may look different depending on your settings.  This section will teach 
you how to adjust your layout settings. 
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1. Click View > Panels in the menu. 
 

 
 

MENU 

 
Standard 
toolbar 

Overview 

P l 

Map 

 Layer  
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2. Uncheck the box next to Layers. 
 

3.  Click View > Panels in the menu. 
 

4. Uncheck the box next to Overview. 
 

What does your QGIS window look like now? 
 

5. Turn the Layers and Overview on by checking the boxes in the View > Panels 
menu. 

 
6. Right click on the Settlements_Cities layer and check the box next to Show in 

overview to the add the layer to the Overview panel. 
 

 
 
QGIS allows you to dock panels on the side of your screen so you have easy access 
to them.  Now you will practice docking and undocking the Layer Panel. 
 

7. Click on the word Layers or on the small grey dots at the top of the Layer 
panel and drag the panel to the middle 
of your screen to undock it.  
 

8. Redock the Layer panel by clicking on the top of the Layers panel and 
dragging the top of the Layers panel to the top of the overview panel. 
 

 
 
9. Release your mouse button when you see the Overview Panel move down 

the screen and the grey dots appear indicating where the layers panel will 
dock, as in this image. 
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NOTE: If you want to dock the Layer Panel when there are no other panels 
open, click on the top of the Layer panel window and drag it to the left wall of 
your map area, or double-click on the top of the panel window.  When the 
grey dotted outline appears, indicating where the layer panel will dock, you 
may release the mouse button. 
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Section 4:  Introduction to the standard toolbar 

The previous section showed you how to adjust your QGIS layout. In this section, 
you will zoom in and out, move, and navigate the map using the standard toolbar.   

1. Click the Zoom In  button on the standard toolbar. 
 

NOTE: The tool that is currently selected will appear with a different color 
background on the toolbar. After you select the Zoom In mode it should look 

like this . 
 
2. Position the magnifying glass pointer to the upper left of a country of your 

choice. 
 
3. Click and hold the left mouse button while dragging your mouse to the 

bottom right of the country of your choice, making a square around the two 
points.   

 
4. Release the mouse. 
 

Now you will see a closer view of the county you chose. 

5. To return to the previous view click the Zoom Last  button. This will take 
you back to the previous zoom level that shows all of Africa. 

 
6. Again, use the same tool to zoom in on Southern Africa. You should now see 

Southern Africa in the center of the map.  
 

 
 

7. Click the Pan Map  button on the standard toolbar. 
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8. Move the cursor hand to the top of your map area.   
 
9. Click and hold the left mouse button while moving the map so that the top 

half of Africa is centered on your map.   
 
10. Release the mouse button. 

 
You will see that the map has been repositioned.  You should now see Northern 
Africa in the Center of the map. 
 

 
 

11. To return to the whole view of Africa, click the Zoom Full   button. 
 

NOTE: The button Zoom Full  button and the Zoom to Layer  
button in this example would give us very similar results.  However, this will 
not always be the case.  The Zoom to Layer button will redraw the map 
zooming to whichever layer is highlighted in the Layer Panel. 

 
 

Section 5:  Introduction to the layer panel 

The previous section showed you how to zoom in and out, move, and navigate your 
map. In this section you will learn to turn a layer on or off using the Layer Panel.   

 
NOTE: The Layer Panel is also called the Table of Contents (TOC). 
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The Layer Panel in QGIS shows you the layers of data that are available to be 
shown on your map.  Think of layers as pieces of data that can be added one on top 
of the other and displayed together. 
In the Layer Panel there currently 4 names: Settlements_Cities, Water_Rivers, 
Water_Lakes, Admin0_Polygons_SSIB.  Notice that there is a check mark    next 
to the Settlements_Cities, Water_Lakes, and Admin0_Polygons_SSIB layers. 
 

1. In the Layer Panel, uncheck the Settlements_Cities check box.  
 
The red dots on the map that show world cities will disappear. 
 

2. In the Layer Panel, check the Water_Rivers check box. 
 

Now you will see blue lines on your map that show rivers. 
 

3. In the Layer Panel check the Settlements_Cities check box so that the cities 
are shown again.   
 

4. Click the Settlements_Cities name so that it is highlighted in blue.  
 

5. Click and hold the left mouse button while moving that layer to the bottom of 
the Layer Panel below the other layers.   
 

Now, the order of the layers from top to bottom is: Water_Rivers, Water_Lakes, 
Admin0_Polygons_SSIB, Settlements_Cities.   

 
6. Most of the dots disappear except for those on small islands and those next to 

the ocean.   
 

7. Click the Settlements_Cities so that it is highlighted in blue.  
 

8. Click on the Settlements_Cities name and move that layer to the top of the 
panel above the other layers.   
 

Now, the order of the layers is: Settlements_Cities, Water_Rivers, Water_Lakes, 
Admin0_Polygons_SSIB. 
 

NOTE:  When organizing layers in your map, think about ordering it with the 
smallest size or area on top. 

 
 
Optional steps: 
 
Try to perform some of the following steps while exploring the functionality of QGIS. 
 

1. Turn on and off the Rivers and Lakes layer in the panel. 
2. Move Water _Lakes to the bottom of the layers panel.  Then move it 

back above Admin0_Polygons_SSIB. 
3. Zoom the map so that you see a country of your choice in detail. 
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4. Change the color of Admin0_Polygons_SSIB to green. 
5. Select a bordering country and zoom to the selected feature. 
6. Pan the map back to your own country. 
7. Zoom to the capital city and create a new Bookmark.  Zoom to Full Extent and 

then zoom to the Capital City Bookmark. 
8. Add a layer to the Overview Panel.   

 
Exit QGIS without saving. 
 
 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 2: Adding vector data 

In this exercise you will learn how to: 
• Add vector files to your map 
• Adjust the properties of layers 
• Modify symbology 
• Add and modify labels 

Section 1:  Start QGIS and add vector data  

You will add a layer, consisting of vector polygon features. 
 

1. Start QGIS Desktop. 
 
2. Open the Layer menu on the top of the screen. 
 

 
 

3. Click Add Vector Layer…  
 
4. Select the Source Type as File. 
 
5. Click Browse. 
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NOTE: The dialog will open to the last place from which you added data in 
QGIS.  

 
6. Navigate to the training folder 

\\Training_Workshop\05_Data\03_Shapefiles\00_Country. 
 
7. Click on the file named DHS_Regions.shp.  
 

 
 

NOTE: Make sure that your file type reads ESRI Shapefiles  [OGR]  (*.shp) 
 
8. Click Open in the “OGR Supported Vector Layer” dialog. 
 
9. Click Open on the “Add vector layer” dialog. 
 
10. There are three ways to add vector layers in QQIS Desktop. 

a. Using the menu option Layer > Add vector layer…  

b. Using the Add vector layer   tool from the toolbar. 
c. Using Ctrl+Shift+V. 

 
NOTE: In all of these methods the same dialog will open and the procedure 
for selecting which data you will add is the same as described above. 

 
 
11. Add the following vector layer: 

\\Training_Workshop\05_Data\03_Shapefiles\00_Country\Cities_Settlements
_0000.shp 
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NOTE: Your map should look similar to this: 
 

 

Section 2:  Change a layer name  

When a layer is added, QGIS assigns it a layer name. Sometimes this name is not 
very descriptive because it inherits the dataset or the feature class name. You can 
rename the layer at any time.  Now, you will change the names of the layers that you 
added. 
 

1. In the Layer Panel, right click (on the text) for the DHS_Regions layer. 
 

 
 
2. Click Properties to display the Layer Properties dialog. 

 

3. Click the General symbol  tab near the top of the dialog box. 
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You should see the following dialog. 
 

 
 

4. For Display name, type:  Regions. 
 

5. Click OK. 
 

NOTE: Your Layer Panel should look similar to this: 
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Section 3:  Symbolize spatial data 

The Regions layer appears in a single color by default. You may want to display the 
Regions in different colors. 
 

1. In the Layer Panel, double-click the Regions layer to open its Properties 
dialog. 

2. Click the Style tab   . 
 

NOTE: In previous versions of QGIS it was called Symbology.   
 
3. Make sure the button near the top right of your screen says Old Symbology. 
 

 
 

NOTE: If you screen looks like the image below, then click on the New 
Symbology  button. Clicking on New Symbology will change it to the newer 
version of QGIS symbology.  You will receive a prompt asking if you wish to 
use the new symbology implementation for this layer.  Click Yes. 

 

 
 
4. Select Categorized from the drop down menu below the Style tab.  
 

 
 

NOTE: If using a previous version of QGIS, select Unique Value in the drop 
down menu next to Legend type. 

 
5. In the new screen that appears within the dialog, select DHSREGEN for the 

Column. 
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NOTE: If using a previous version of QGIS, Column is called Classification 
field. 

 
6. Click on the Color ramp drop down menu. 
 

 
 
7. Select New color ramp… 
 
8. Select ColorBrewer for the Color ramp type. 
 

 
 
9. Select the Spectral Scheme name. 
 
10.  Select 10 for the number of colors. 
 
11. Call the new color ramp Spectral. 
 
12. Click OK. 
 
13. Click Classify. 
 

 
 
14. All the Regions will appear in the window, with an assigned color. 
 
15. Double click on the first Region symbol in the list. 
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16.  In the Symbol selector window that appears, you will be able to change the 
color for the highlighted region by clicking the Change button in the middle of 
the window.  

 
NOTE: If using a previous version of QGIS, click on the first Region name in 
the list.  In the right side of the dialogue window, you will be able to change 
the color for the highlighted region. Click on the colored box in the Fill 
Options area. 

 

 
 
17. Select a new color.  
 
18. Click OK to close the color selection. 
 
19. Click OK to close the Layer Properties dialog. 

 
Next, you will change the symbol for the Cities. 

 
20. Double-click the Cities_Settlements_0000 layer in the Layer Panel to open its 

Layer Properties dialog. 
 
21. Click the Style tab. 
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22. Click the Change button in the middle of the window. 
 

 
 

NOTE: If you are using a previous version of QGIS, you will change the 
symbol Scroll down (using the scroll on the far right of the dialog) until you 
see Fill options. 

 
23. Click on the black box under the Basic colors options. 
 

 
 
24. Click OK to close the color selection. 
 
25. Click OK to close the Layer Properties dialog. 
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Section 4:  Label features  

A map is incomplete without some labeled features. Placing names on your map is 
an important communication task.  Map readers should be able to find names quickly 
or they will not use your map.  Now, you will place the name of the Regions on the 
map. 
 

1. Select the Regions Layer in the Layers box by clicking once on it so it is 
highlighted blue. 
 

 
 

2. Click the Layer menu > Labeling to open the Layer labeling settings dialog.  
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3. Check the Label this layer box to label Regions. 
 
4. Select DHSREGEN  from the Label this layer with drop down menu located 

in the top. 
 

 
 
5. Click the button with three dots in the Text Style section of the Label settings 

tab. 
 

 
 
6.  Select MS Serif, Bold, 10 (size) from the Select Font window. 
 
7. Click OK. 
 
8. Click Color and select black. 
 
9. Click OK to close the color selection. 
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10. Click OK to close the Layer labeling settings dialog. 
 

NOTE: Your map should look something like this.  The colors will be 
different. 

 
 

Section 5:  Save your map document  

You will save your map document for future use.   You can save your file with 
absolute or relative paths.  This refers to how the QGIS file will remember where the 
data corresponding to each layer is located.  Absolute path means that QGIS will 
always look in the same file location (exact location on the computer for the data 
while relative path means that QGIS will look for the data to be in the same place in 
relation to the QGIS file (such as in the same folder or 2 folders away in a folder 
called 02_Data.)  Relative paths are in general better if you might move your folders 
and or share your *.QGS files with a colleague. 
 

1. Click Settings > Project Properties. 
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2. Open the General tab. 
 
3. Change Save paths to relative under General settings. 

 

   
 
4. Click ok to close the dialog. 

 
5. Click File > Save Project as... 

 
6. Save the file in \\Training_Workshop\06_Participant_Work. 

 
7. Name the file Adding_Vector_Data.   
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8. For Save as type, confirm QGIS Project File (*.qgs). 
 

 
 

9. Click Save. 
 
Optional steps: 

1. Add the road layer to the map. 
 

2. Change the road color to a different color. 
 

3. Change the road line width. 
 

4. Symbolize the road layer according to the road type. 
 
EXERCISE END 

MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 3:  Joining data 
 
In this exercise you will learn how to join data from an excel table to spatial data in 
QGIS.  Since the shapefile contains multiple, unique records, the data to be linked 
must be in the same form.  For example, numbers joined to numbers or text joined to 
text.  If a text field name is used for linking, the spelling in the two files must be 
exactly the same.   
 

Section 1:  Join attributes 

The DHS_Regions layer only contains the regional names and geographic 
information. You will join the Region_Data file to the DHS Regions layer in order to 
display the indicator data contained in the excel file. 
 

1. Launch the QGIS Desktop application. 
 
2. Click File > Open. 
 
3. Navigate to 

\\Training_Workshop\04_Exercises\Project_files\Joining_Data.qgs. 

4. Click the Add Vector Layer  button from the toolbar. 
 
5. Click the browse button. 
 
6. Select All file (*) (*,*) from the file type menu on the bottom right. 
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7. Navigate to 

\\Training_Workshop\05_Data\01_Excel\00_Country\Indicators.xls 
 
8. Click Open. 
 
9. Select the REGIONAL_DATA layer from the Select vector layers to add… 

window. 
 

 
 
10. Click OK. 
 
11. Right click on the REGIONAL_DATA layer and select Open attribute table. 
 
12. Explore the attribute table. 
 
 NOTE: Open the file \\Training_Workshop\05_Data\01_Excel\Indicators.xls 

and click on the Indicator Key tab for descriptions of each of the indicators in 
the REGIONAL DATA layer. 

 
13. Right click the DHS_Regions layer in the Layer Panel and select Properties. 
 
14. Click the Joins tab in the Layer Properties window. 
 

 
 

15. Click the plus  button. 
 
16. Set Join layer  to REGIONAL_DATA. 
 
17. Set Join field to DHS_Region. 
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18. Set Target field to DHSREGEN. 
 

Your Add Vector Join window should look like this example. 
 

 
 
19. Click OK. 
 
20. Click OK to close the Layer Properties window. 
 
21. Right click on the DHS_Regions layer and select Open attribute table. 
 
22. Scroll to the right to see the newly joined data. 
 

You should see the data for select variables joined to the appropriate region.  You 
can now map these data or send this file to colleagues.   

 
 NOTE: If the attribute table does not contain the data for the variables you 

just attempted to join, go back to the .xls file to ensure that the Join field is 
spelled exactly the same as the target join field from the shapefile. If there 
are any differences in spelling, accents, hyphens, or one field contains extra 
spaces, the attribute join will not work for that record. 

 
The joined data is currently being stored in virtual memory. To save the join 
permanently, you must export it as a new layer. 

 
23. Right click on the DHS_Regions layer and select Save as... 
 
24. Click Browse for Save as, navigate to 

\\\Training_Workshop\06_Participant_Work and name the shapefile Pilot_join 
 
25. Click Save. 
 
26. Select Layer CRS for CRS. 
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27. Check the box next to Add saved file to map. 
 

The resulting window should look like this: 
 

 
 
28. Click OK. 

 
 
 

Section 2:  Join attributes by location 

Now we will join the Cities data to the Regions based on location.  Although the 
Cities data already indicate to which Province they belong, this task will function as a 
data check. 
 

1. Click Layer > Add Vector Layer… 
 
2. Browse to //Training_Workshop/05_Data/03_Shapefiles/00_Country/ 

Cities_Settlements_0000 
 
3. Click Open. 
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4. Click Vector > Data Management Tools> Join attributes by location. 
 

 
 
5. Set Target vector layer field to Cities_Settlements_0000. 
 
6. Set Join vector layer to DHS_Regions. 
 
7. Set Attribute Summary to Take attributes of first located features. 
 
8. Set the Output Shapefile folder to \\Training_Workshop\06_Participant_Work 

and name the shapefile Reg_Cities_Join. 
 
9. Set Output Table to Keep all records (including non-matching target records). 
 

NOTE: The resulting window should look like this. 
 

  
 
10. Click OK.  
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11. In the pop-up box, click Yes to 'Would you like to add the new layer to the 

TOC?' 
 
12. Then click Close. 
 
13. Right click on the Reg_Cities_Join layer, select Open attribute table. 

 
You should now see the Regional attribute information for each City as new fields.   
 
 

Optional steps: 

Below is output from STATcompiler.com for the Kenya 2008-09 DHS: 

Country Survey Sub-national 

Place of delivery: Health 
facility (Births in three years 

preceding the survey) 
Kenya 2008-09 DHS Region: Nairobi 90.3 
Kenya 2008-09 DHS Region: Central 74.6 
Kenya 2008-09 DHS Region: Coast 46.9 
Kenya 2008-09 DHS Region: Eastern 43.6 
Kenya 2008-09 DHS Region: Nyanza 43.6 
Kenya 2008-09 DHS Region: Rift Valley 32.7 
Kenya 2008-09 DHS Region: Western 28.4 
Kenya 2008-09 DHS Region: North Eastern 18.7 

 
 

1. Copy the table to excel. 
 

2. Clean the table to prepare the data for joining in QGIS. 
 
HINT: Make sure the region names match the spelling of the region names in 
the shapefile within QGIS. 
 
HINT: Shorten the name of the indicator to 10 characters or less. 

 
3. Join the attributes from the .xls file to the DHS_Regions shapefile. 

 
4. Check the join to verify that the indicator values for all regions joined properly. 

 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government.
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QGIS Exercise 4:  Displaying data 
 
In this exercise you will learn how to categorize data to make a thematic or 
chloropleth map.  A thematic map is a useful way to show data for multiple areas at 
one time.  This data can be related i.e. nominal or unrelated i.e. ordinal.   
 
 

Section 1:  Classify with Graduated Renderer  

The Indicator_join layer appears in a single color by default. You will categorize the 
variables with one color using a method called graduated renderer. 
 

1. Open QGIS Desktop 
 
2. Click File > Open project 
 
3. Browse to \\Training_Workshop\04_Exercises\Project_files\ 

Displaying_Data.qgs. 
 
4. Click Open. 
 
5. In the Layers Panel, right-click the Indicators_join layer to open its Layer 

Properties dialog box 
 

6. Click the Style tab . 
 
 NOTE: In previous versions of QGIS it was called Symbology.   
 
7. Make sure the button near the top right of your screen says Old Symbology. 
 

 
 
 NOTE: If you screen looks like the image below, then click on the New 

Symbology  button. Clicking on New Symbology will change it to the newer 
version of QGIS symbology.  You will receive a prompt asking if you wish to 
use the new symbology implementation for this layer.  Click Yes. 
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8. Select Graduated from the drop down menu directly below the Style tab. 
 

 
 
9. Select HIV_Preval for the Column. 
 

 
 
10. Select the blue(s) color ramp. 

 
 
 
 
11. Select 3 classes. 
 

  
 
 NOTE: By default the Mode is set to Equal Interval. 
 
12. Click Classify. 
 
13. Click Apply. 
 
14. Move the Layer Properties dialog box over to see the changes on the map. 
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The country is now various shades of blue calculated by grouping the HIV 
Prevalence variable into three classes. Each class is now listed in the Layer Panel 
with the color and label. 

 

 
 

Now you will change the classification scheme for the data to Quantile. 
 
15. In the Layer Properties Symbology panel, change the Mode to Quantile 
 
16. Change the number in the Classes box to 4, this will change the number of 

categories from 3 to 4. 
 
17. Click Classify. 
 
18. Click Apply and move the Layer Properties dialog box to see the changes on 

the map 
 
19. The range and label of the classification may need to be adjusted to make it 

user friendly.  Double click on the Range values you want to adjust. 
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20. Then set the lower and upper values of the range. NOTE: Make sure you do 
not to have either overlaying ranges or gaps in the range.  

 

 
 

For Example: 
Class    Correct   Incorrect Issues 
  1        0 – 10   0 - 10 
  2     10.1 – 15   9 -15  Overlap 
  3     15.1 – 20   15.1 - 20 
  4      20.1 – 25   21- 25 Gap 

 
21. Double click on the label value you want to adjust and change it to match the 

range. 
 

  
 
 NOTE: If you make a mistake and want to return to the original classification 

then click  
 
22. Click Apply. 
 
23.  Move the Layer Properties dialog box over to see the changes on the map 

and the legend. 
 
24. Click  Ok. 

 
 

 

Section 2:  Classify with Categorized Renderer  

You will now categorize the variables with multiple colors using a method called 
categorized renderer. 
 

1. Check the box next to the Roads layer to turn it on. 
 
2. Open the Layer Properties Style panel for Roads. 
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3. Change the drop down menu directly below the Style tab to Categorized. 
 

  
 
4. Select RTT_DESCRI for Column. 
 
5. Select New color ramp… from the Color ramp drop down menu. 
 
6. Select ColorBrewer in the Color ramp type window. 
 
7. Click OK. 
 
8. In the ColorBrewer ramp window, select Spectral for the Scheme name. 
 
9. Select 5 for colors. 
 
10. Click OK. 
 
11. Enter Spectral Ramp for the color ramp name. 
 
12.  Click OK. 
 
13. Click Classify. 
 
14. Click Apply and move over the Layer Properties dialog box to see the 

changes on the map. 
 
What do you see?  Which Roads are similarly colored?  How might this method be 
useful and what attribute data is necessary?   
 
 
 
Optional steps: 
Try to perform the following steps while exploring symbologies. 

1. Select a different attribute and classify using Graduated Symbol. 
a. Create your own custom category breaks.   
b. Are all Provinces displayed? Why did you choose those break values? 

 
2. Classify another Indicator code of your choice  

a. Graduated Symbol, Equal Interval, and  5 Classes  
b. Change the number of classes to 3 
c. What would be a better way to display this data? 
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3. Classify any variable using New Symbology, Graduated Renderer, 20 

Classes. 
a. What happened?  Why do you think this is? 

 
 
Exercise End 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 5:  Coordinate Systems 
 
This exercise will teach you the fundamentals of Coordinate Systems within QGIS.  
In this exercise you will learn: 
 

• How to determine the coordinate system of a layer 
• How the projection of your map affects distance measurements 
• How to add a custom projection to QGIS 
• How to choose the best Projected Coordinate System for your map 

 
 

Section 1:  Determining the Coordinate Reference System (CRS) of a layer 

1. Open the folder \\Training_Workshop\04_Exercise_Templates\Project_files. 
 
2. Double click on the QGIS file called Coordinate_Systems.qgs. 

 
3. Right-click on the Admin0_Polygons_SSIB layer and select Properties. 

 

 
 
 

4. Click on the Metadata tab  
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5. Look to the bottom of the window for information on the CRS listed under 
Layer Spatial Reference System. The coordinate system of the layer is circled 
in red below.  It shows that the layer is in the WGS84 coordinate reference 
system. 

 

 
 

Now you will use a different method to look at the CRS information for the layer. 

6. Click on the General tab . 
 
The coordinate system of the layer is circled in red below.  It shows that the layer is 
in the WGS84 coordinate reference system. 

 

 
 

7. Click the Specify CRS button to view more information about the coordinate 
system.  
 

When the Coordinate Reference System Selector window opens, the WGS 84 row is 
highlighted.  

 
8. Scroll all the way to the top to determine which type of coordinate system 

WGS 84 is.  You see that WGS84 falls under the Geographic Coordinate 
Systems classification. 
 
NOTE: If the Coordinate reference system of a layer is a Geographic 
Coordinate System the units of the layer will be in either decimal degrees or 
degrees, minutes, seconds.  There will be only 1-3 digits to the left of the 
decimal point. 
 
NOTE: If the Coordinate reference system of a layer is a Projected 
Coordinate System the units of the layer will be in either meters or feet.  
There will be 6-8 digits to the left of the decimal point. 
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Section 2:  A projection’s affect on distance measurements 

 
A Projected Coordinate System transforms the earth’s surface to a two dimensional 
grid with units of either meters or feet.  Because the earth is not actually a flat grid, 
no projection is a completely accurate representation.  There are many different map 
projections that are designed to preserve either shape, distance, area of land, or a 
combination of these. 
 

Google Mercator is an example of a Projection that preserves shape by 
ensuring that all latitude and longitude lines cross each other at 90 degree 
angles: 
 

  
 
 

Lambert Plate Carree Equidistant Cylindrical is an example of a Projection 
that preserves distance: 
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Lambert Azimuthal Equal Area is an example of a Projection that preserves 
area: 
 

 
 
 
 
Robinson is an example of a Projection that is a compromise to preserve as 
much shape, distance, and area as possible: 
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To observe the differences in projections, you will measure the distance between two 
cities using different projections and compare the results.  Tunis, Tunisia and Cape 
Town, South Africa are shown as green and blue points on your map.  In order for 
you to measure the distance in units of meters, a projected coordinate system that 
uses meters for units must be used.  The Google Mercator projection, which will be 
used for this exercise, is one example of a projection that uses meters. 
 

 
1.  Click on the CRS Status button at the bottom right corner of your QGIS 

window. 
 

 
 
 
2. Check the box  to allow your layers in the WGS 

84  CRS to be automatically transformed and mapped in the new projection 
you will select for your map document. 
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3. Type 900913 into the Filter section. 
 

 
 
4. Click on the Google Mercator Projected Coordinate System to select it. 
 
5. Click OK. 
 
6. Right click on the Admin0_Polygons_SSIB layer. 
 
7. Select Zoom to layer extent. 
 

Now that a projection has been set, you will measure the distance between two 
points.  

8. Click the Measure Line button . 
 
9. Click on the map. 
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10. Uncheck the  box in the Measure window that opens 
 

NOTE: Unchecking the ellipsoidal box means that the distances using the 
measure tool will be calculated based upon the projection.  If the box is 
checked, the distances will be calculated based upon the WGS 84 ellipsoid.  
The box should only be unchecked for this exercise, which is to demonstrate 
the variation in distances calculated from projections. 

 
11. Click the New button in the Measure window to begin a new measurement 

segment. 
 
12. Move the cursor directly over Tunis (the green point) and click once. 
 
13. Move the cursor over Cape Town (the blue point) and click once. 
 
14. The distance in meters between the two cities will display as the first 

segment in the Measure window. 
 

NOTE: It is ok if your distance is slightly different from this example. 
 

 
 
15. Record the distance and label it Google Mercator. 
 
16. Close the Measure window. 
 
17. Click on the CRS Status button at the bottom of your QGIS window. 
 
18. Make sure the  box is checked. 
 
19. Type 3035 into the Filter section. 
 
20. Select the Lambert Azimuthal Equal Area > ETRS89 / ETRS-LAEA Projected 

Coordinate System. 
 
21. Click OK. 
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22. Right click on the Admin0_Polygons_SSIB layer. 
 
23. Select Zoom to layer extent. 
 

Now that a different projection has been set, you will measure the distance between 
the same two points as a comparison.  

24. Click the Measure Line button . 
 
25. Move the cursor directly over Tunis (the green point) and click once. 
 
26. Move the cursor over Cape Town (the blue point) and click once. 
 
27. The distance in meters between the two cities will display as the first 

segment in the Measure window. 
 
28. Record the distance and label it Lambert Azimuthal Equal Area. 
 
29. Close the Measure window. 
 
30. Calculate the difference for the distance between the two cities under the 

Google Mercator and the Lambert Azimuthal Equal Area projections. 
 
 

Section 3:  Adding a custom projection to QGIS 

QGIS contains many different options for CRS settings.  However, there are not any 
compromise projections available, which are the most popular projections to use 
when creating a map of a continent or the entire world.  This section will teach you 
how to add the Robinson compromise projection and save it in your QGIS settings 
for use in the future.   Refer back to Section 2 for an explanation of the Robinson and 
other compromise projections. 
 

1. Select Custom CRS from the Settings menu 

 
 

2. Click the star  button to add a new empty entry 
 

3. Name the CRS Robinson 
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4. Type or copy and paste: +proj=robin +lon_0=0 +x_0=0 +y_0=0 
+ellps=WGS84 +units=m +no_defs  into the Parameters box 
 

Your Custom Coordinate Reference System Definition window should look like this 
example. 
 

 
 

5. Click the save  button to save the projection to your CRS library 
 

6. Click OK. 
 

7. Click on the CRS Status button at the bottom right corner of your QGIS 

window  
 

8. Make sure the  box is checked 
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9. Type Robinson into the filter box 

 
The Robinson projection you added should appear under the User Defined 
Coordinate Systems section.  Note that the Authority ID will automatically be 
assigned based upon the order in which you add new custom CRSs. 
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Section 4:  Choosing the proper projection 

Section 2 showed the difference in distances across projections.  That variation 
makes it important to choose the proper projection for your analysis.  This section 
provides a flow chart to help you select the best projected coordinate system for your 
project. 

 
If you have gone through the flow chart and it tells you to select a WGS 84 / UTM 
zone, follow the steps below. 
 

1. Determine whether your area of interest falls into the northern or southern 
zones.  The dividing line between the zones is the equator. 

 
 

2. Determine the zone number for your area of interest from the image below.   
 
NOTE: You may also use an interactive map to zoom in to your area of 
interest and see which UTM zone to use.  The map is available online 
at: http://whatutmzoneamiin.blogspot.com/p/map.html. 

Will you be conducting 
spatial analysis or making a 

map? 

Making a map 
How large is your 
area of interest? 

One small-medium 
sized country 

Find the appropriate 
WGS 84/UTM zone 
projection from the 

attached map. 

A large country or more 
than one country 

Use a world compromise 
projection such as 
Robinson (Refer to 

Section 3 to add this 
projection) 

Spatial Analysis 
How large is your 
area of interest? 

One small-medium 
sized country 

Find the appropriate 
WGS 84/UTM zone 
projection from the 

attached map. 

A large country or more 
than one country 

Use a world equi-distant 
projection such as World 
Equidistance Cylindrical 

Sphere (Authority ID: 
3786) 

http://whatutmzoneamiin.blogspot.com/p/map.html�
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EXERCISE END 

MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government.
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QGIS Exercise 6:  Map layout  
 
In this exercise you will learn how to use the QGIS Print Composer, add map 
elements to the map to make it more useful, and export the map. Map elements 
include a legend, a map title, a scale bar, dates for the data and map, the name of 
the author, and other textual disclosures or pertinent information. 
 

NOTE: This exercise is about how you add the different map elements and 
manipulate their characteristics. This does not imply, however, that you 
should have all these elements in every map you make. The map objectives 
and individual map specifications at your organization or supplied by your 
client will dictate what map elements are important to include in each map. 

 
 
 

Section 1:  Start QGIS and set the map projection 

First, launch the QGIS application (if not already open). 
 

1. Click File > Open. 
 
2. Navigate to \\Training_Workshop\04_Exercises\Project_files. 
 
3. Double click Map_Layout.qgs to open the map. 
 

The Map_Layout project file is currently in the WGS84 Geographic Coordinate 
System, which means the units are in decimal degrees.  To make sure that your map 
displays units that are easier to understand (such as meters or kilometers,) you must 
change the map to a Projected Coordinate System.  The recommended projection 
for Kenya is WGS84/UTM zone 37S. 

 
4. In main Map Window Click on Settings > Project Properties. 
 
5. Click on the Coordinate Reference System (CRS) tab. 
 
6.  Check the box next to Enable 'on the fly' CRS transformation 
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7. Type “32737” into the filter box OR scroll down to the Coordinate Reference 
System called “WGS84/ UTM zone 37S” and select it by clicking on it. 

 

 
 
8. Click OK 
 
9. In main map Window select the DHS_Regions layer 
 

10. Click on Zoom To Selected  
 
 
 

Section 2:  Start a new print composer session 

Print composer is the interface in QGIS for creating a map layout for export or print.   
 

1. Click the Print Composer   button 
 

2. Click the Add new map  button 
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3. Now, in order to add the map, hover the mouse over the top left corner of the 

white page. Click and hold the left mouse button and move the mouse right 
and down to create a square on the white page.  Release the mouse button.   

 
The placement of your map object should look similar to this. 

 

 
 
4. You should see the same data from the map display.  This is what will be 

exported. 
 
5. Select the map by clicking in the map. In the corners you will 

see little light blue squares that it indicates the object (map) is 
selected. 

 
 
6. If the scale of the map is not as desired then click on the Item Properties tab 

on the right sidebar.  
 
7. Click on Extents in the Item tab. 
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8. Click on Set to map canvas extent.  This will adjust the viewing area of your 
map object to best show the layer of interest, which is the DHS regions in this 
case.  

 

 
 
9. To center the map on the country of interest, select the Move item content 

button  .  Move the mouse to the map, click and hold the left mouse 
button and drag the country of interest to the center. 

 
10. You may close the Command history panel if you wish by clicking on the  

at the top right hand corner of the panel. 
 

 

Section 3:  Save a template of your map 

It is a good idea to save your work frequently when working the in the Composer  
window. 
 

1. In the Composer window, go to the File menu and select Save as template. 
 

2. Navigate to \\Training_Workshop\06_Participant _Work and name the file 
Map_Layout. 
 

3. Click Save. 
 

4. Repeat this save process throughout the exercise to make sure you do not 
lose your work. 
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It is easy to accidentally close your Composer  window, so we will practice how to 
reopen your saved template. 

 
5. Click the Close button on the bottom of the Composer  window. 

 

6. Click the Print Composer   button. 
 

7. Click File > Load from template OR the Load from template   button to 
open your saved template. 
 

8. Browse to \\Training_Workshop\06_Participant _Work\Map_Layout.qpt 
 

9. Click Open 
 
 

Section 4:  Add a title and citation 

1. Use the Add new label  button to create a descriptive title. 
 
2. Click on the top of the page to insert a label. 
 
3. Select the Item Properties tab then the Label tab in the box on the right side 

of the screen. 
 
4. Enter a title (e.g. Percentage of Males age 15 – 49 Who Have Ever Been 

Tested for HIV and Received the Results) in the Label box. 
 
5. Set the Font and Font color… using the buttons under the Item menu. 
 

 
 
 NOTE: As the title of your map, it is important to make sure that the font size 

is large enough for others to read easily.  Setting the font style to bold is 
another way to make the title easier to read.  

 
6. Click on the General options tab. 
 
7. Un-check the box under General options – Show frame to remove the frame 

from around the title. 
 
8. Adjust the size of the title box but dragging the corners of the box until all the 

text is visible. 

9. Click the Add new label button .  
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10. Click on the empty space on right side of the map layout. 
 
11. In the Item tab, click on the Label tab and type a citation for the data values 

in the map.  For example: “Data are from the Kenya 2008-09 Demographic 
and Health Survey Final Report authored by the Kenya National Bureau of 
Statistics, Nairobi, Kenya and MEASURE DHS, ICF International, Calverton, 
Maryland, USA.” 

 
12. Resize the box so all of the text is visible. 
 
13. Save your map template. 

 
 

Section 5:  Add a legend 

1. Add a legend by selecting the Add new vector legend  button. 
 
2. Click on the top-right of the page to insert the legend. 
 
3. Select the legend by clicking on it so the blue squares in the corners appear. 
 
4. Click on the Item Properties tab on the ride side of the window. 
 
5. Click on the Legend items tab. 
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6. Order the items by selecting the layer in the Legend items box and clicking 
on the up and down arrows. 

 

 
 
7. Remove the Admin0_InternalLines_LSIB layer from the Legend by selecting 

the layer so it is highlighted blue, then clicking the minus button . 
 
8. Edit the layer name for the Regions layer by selecting the layer, then clicking 

the Edit button .  Name the layer Percent by region. 
 
9. Save your map template. 

 
 
 

Section 6:  Add a scale bar 

1. Add a scale bar by selecting the Add new scalebar  button. 
 
2.  Click on the map where you want your scale bar to be placed. 
 
3. Select the Item Properties tab on the right side of the window.  
 
4. Select the Scale Bar section.  
 

The Segment Size number is the number of units (meters in this case) that each 
section of the scale bar is equal to.  The Segment size (map units) will automatically 
set itself to the scale and units of the map.  The default segment size always starts 
with the number one. For this map, the default segment size is too small, so you will 
change the first number from 1 to 2. 

 
5. Set the Segment size to 200000. 
 
 NOTE: This sets each section of your scale bar equal to 200,000 meters. 
 
6. Adjust the Map units per bar unit to 1000.  This converts the units of the 

scale bar from meters to kilometers. (1000 meters per kilometer) 
 

7. Make sure that Map 0 is selected under the Map section.  This links your 
scale bar to the first (primary) map you added to your Layout. 
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8. Enter the Unit label as Kilometers. 

 

9. Adjust the box around the scale bar by dragging the corners to fit the size of 
the bar. 

 
10. Under General options, change the Opacity to clear by dragging the slider all 

the way to the left. This will make the box around the scale bar see through. 
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11. Un-check Show frame.   
 
12.  Save your map template. 

 
 

Section 7:  Add a locator map 

One way to provide context for a map is to include a locator map.  The locator map is 
second map that shows the reader where the area of interest is located. 
 

1. Click the Add new map  button. 
 
2. Click and hold the left mouse button and drag the mouse to create a small 

map in the bottom right corner of the page.  Release the mouse button.   
 

The placement of your locator map should look similar to this, but with your own 
content. 

 

 
 
3. Select the locator map, by clicking on the map. In the corners you will see 

little light blue squares that indicate the object (map) is selected. 
 
4. Using the scroll button on your mouse, zoom out by scrolling down until you 

see all of Africa. 
 

5. Select the Move item content button  .   
 
6. To center the map on Africa move the mouse to the map, click and hold the 

left mouse button and drag to center the map. 

7. Click the Select/Move item button  . 
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8. Select the main map, by clicking on it. In the corners you will see little light 
blue squares that indicate the main map is selected. 

 
9. Click on the Item tab. 
 
10.  Click on the Map section.  
 

11. Check the box Lock layers for map item.  
 
 NOTE: This locks the layers of your main map so that the main map layout 

will not update if new layers are added to your project file. 

12. Go back to the main QGIS window and click the Add vector layer button 
. 

 
13. Browse to and open the file 

\\Training_Workshop\05_Data\03_Shapefiles\00_Country\DHS_Regions. 
 
14. Open the layer properties for the DHS_Regions file. 
 
15. Change the fill color to black and click OK. 
 
16. Click OK in the layer properties window. 

17. Go back to your Composer window and click the Refresh view button . 
 

The country of interested should have turned black in the locator map only. 
 
 NOTE: If the DHS_Regions file was automatically added to your legend, 

select the legend, go to the Legend Items tab in the Item tab, select the 
DHS_regions layer, and click the minus button to remove it. 

 
18. Save your map template. 

 
 
 

Section 8:  Export as a PDF 

1. Click the Export as PDF   button. 
 

2. Give your map an appropriate file name and save it to 
\\Training_Workshop\06_Participant _Work. 
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3. Navigate to the newly created PDF and open the document. 

 
Does the map look as you intended?  Below is just one example of a possible output.  

 
 

Section 9:  Export as an image 

1. Export the map as an image using the Export as Image . 
 
2. Choose JPEG in Save as type and enter an appropriate location on your 

computer. 
 
4. Give your map an appropriate file name and save it to 

\\Training_Workshop\06_Participant _Work. 
 
3. Navigate to the newly created JPG and open the document. 

 
Does the map look as you intended?   
 
 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 7:  Querying data 
 
In this exercise you will learn how to perform queries in QGIS including selections 
and structured query language (SQL) queries.  A query is a useful way to better 
understand your data and to answer questions with your data. 
 

Section 1:  Use identify features tool 

The Identify Features  button allows you to see attribute information about a 
feature in a layer. 
 

1. Navigate to the \\Training_Workshop\04_Exercises\Project_files folder and 
locate Querying_Data.qgs 

 
2. Double click Querying_Data.qgs to open and display the map. 
 
3. Click on the DHS_Regions layer the Layer Panel to highlight it. 
 
 NOTE: The Identify Features tool will always provide you with information 

from whichever layer is highlighted in the Layer Panel.  Therefore, you must 
check to make sure that the layer of interest is highlighted. 

4. On the toolbar select the Identify Features  button. 
 
5. Click on a region on your map.  A dialog box will open that lists all the 

attributes for that region. 
 
6. Click on one of the Cities. 
 
 NOTE: What happened?  Did you get the attribute data for the region instead 

of for the City?  Make sure that the Cities_Settlements_0000 layer is selected 
in the Layer Panel.  Also, make sure that when you click, the mouse arrow is 
at the center of the City point on the map. 

 
7. Close the Identify Results dialog box. 

 

Section 2:  Spatial selection 

There are two ways to select features, spatially or by attribute.  This section will 
show you how to select individual features or multiple features spatially. 

1. On the toolbar, click the Select single feature   button. 
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2. Make sure that the DHS_Regions layer is highlighted in the Layer Panel. 

 
NOTE: The Selection tool will only select features from the highlighted in the 
Layer Panel.  Therefore, you must check to make sure that the layer of 
interest is highlighted. 

 
3. Click on a region on your map.  The region will turn a different color (yellow or 

red are the common default settings). 
 

4. Click on a different region. 
 
NOTE: What happened?  The original region is no longer highlighted.  The 
newly selected region should now be highlighted. 
 

5. Click on a new region. 
 

6. Hold the CTRL key and click on several other regions. Now several regions 
should be selected. 

7. Click the Deselect features from all layers  button. 
 
 

Section 3:  Exploring attributes 

Selecting by attribute requires some understanding of the data available in the 
attribute table and the way in which the data are represented. 

 
1. Double click the DHS_Regions layer in the Layer Panel. 
 
2. Click the Fields  tab in the Layer Properties dialog box. 
 

NOTE: In the box, you will see the information about each attribute in the 
attribute table.  These are descriptions of the attribute categories i.e. column 
names, type (String, Integer, or Real), length, and precession (number of 
decimal places). 

 
3. Close the Layer Properties dialog box. 
 

Make sure that the DHS_Regions layer is highlighted in the Layer Panel. 

4. Click the Open Attribute Table  button on the toolbar. 
 

NOTE:  You can also access this dialog box by right clicking the layer in the 
layer panel and clicking Open Attributes Table button.  Or, you when the 

layer is selected in the Layer Panel, click the Open Attributes Table  
button.    

 



 

MEASURE DHS and MEASURE Evaluation GIS Training 
QGIS Exercise 7: Querying Data 

104 
 

5. Click the DHSREGEN header   in the Attribute table. 
 

NOTE: This will reorder the rows so that they are in alphabetical order 
starting with A.  If you click the header again it will reverse the sort order. 

 
6. Click the Shape_Area header. 
 

NOTE: This will reorder the rows so that they are in numerical order from 
smallest to largest.  If you click the header again it will reverse the sort order. 

 
7. Select the rows Central, Nyanza, Coast, and North Eastern by clicking and 

holding the left mouse button as you drag it across the gray numbers on the 
far left of the table. 

 

 
 

NOTE:  You can also select in the attribute table by clicking the first row and 
holding the SHIFT key then clicking the last row in a continuous selection.  
For a non-continuous selection, hold the CTRL key and click each row that 
you want to select.  To unselect something in the table hold the CTRL key 
and click the row number. 

 

8. Check the box for Show selected only  (located in the bottom 
left of the dialog box). 

 
NOTE: What happened?  You should see only the selected rows.   

 
9. Uncheck the box for Show selected only. 
 
10. Explore the use of the other select tools in the attribute table (at bottom left of 

dialog). 
 

 
 
11. Close the dialog box by clicking on the X in the upper right corner. 
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Section 4: Selection by attribute using advanced search 

Advanced Search in QGIS allows you to select features using structured query 
language (SQL) with clause operators such as equal to and greater than.  This is 
important for querying data and making new layers. 

 
1. Open the Attribute table for the Cities_Settlements_0000 layer. 
 

2. Click Advanced search.   
 
3. Double click POP_CLASS in the Fields box.  That field will appear in the SQL 

where clause box. 
 

4. Click in the Values area.  The names of all the population 
classifications appear in the values box. 

 

5. Click the equal sign in the Operators area. 
 
6. Double click '500,000 to 1,000,000' in the Values area. 
 

7. In the Operators area, click the OR button.  
 
8. Double click POP_CLASS in the Fields box. 
 

9. In the Operators area, click the equal sign.  
 
10. Double click ‘1,000,000 to 5,000,000' in the Values area. 
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The Search Query Builder window should look like the example below. 
 

 
 

11. Click Test.   
 

A dialog box should appear that tells you that two matching features were found. 
 
12. Click OK. 
 
13. Clear the SQL where clause box. 
 
14. Enter the following in the SQL where clause box by typing or using the 

operators: POP_RANK !=  7 
 
15. Click Test.   
 
16. Click OK in the Search Results dialog box. 
 
17. Click OK in the Search query builder dialog box.   

 
You will now see 4 cities highlighted in the Attribute table.  The highlighted cities are 
those with a population rank that does not equal 7.  The population rank of 7 
corresponds to the population class of Less than 50,000.  Therefore, the highlighted 
cities are those with a population of 50,000 or more. 
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18. Close the Attribute table using the X in the upper right corner. 
 

NOTE: How many cities are selected on the map?  Where are they located? 

19. Clear all selections using the Deselect all features from layer  button. 
 
 
 
 

Section 5:  Create a new layer from a selection 

Sometimes you want to create a new layer with the information you have selected.  
This might be used for further querying or for display purposes. 
 

1. Open the Roads layer's Attribute table. 
 
2. Uncheck the box next to Case sensitive. 
 
3. Type Primary Route in the bottom right corner in the Look for box. 
 
4. In the in drop down menu, select RTT_DESCRI. 
 

 
 
5. Click Search. 
 
6. Click the Show selected records only box in the bottom right of the dialog.  

This will show the Attribute table with only the selected rows.   
 
7. Close the Attribute table using the X in the upper right corner. 
 
8. Click Layer > Save Selection as Vector file... 
 
9. Make sure the Format is ESRI Shapefile. 
 
10. Navigate to \\Training_Workshop\06_Participant_Work and name the file 

Primary_Roads.shp. 
 
11. Check the box next to Add saved file to map.   
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The Save vector layer as… window should look like the example below. 
 

 
 
12. Click OK. 
 
13. Click OK. 
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Section 6: Attribute calculation 

The Field calculator  button allows you to make calculations in the Attribute 
table on a single column or using multiple columns. 
 

1. Click the box next to Indicators_join to turn the layer on.  

 
 
2. Open the attribute table for the Indicators_join layer. 
 

3. Click the Toggle editing mode  button. 
 

WARNING: This activates the editing mode.  You can change the attributes 
and geometry. You might want to save your layer as a new layer before 
performing any edits.  Once you save your edits, you cannot go back to a 
previous version of the layer unless you have another copy of it saved. 

4. Click the Open field calculator  button.   
 
5. Type “Pop_Dens” in the Output field name box. 
 

NOTE: If the Output field options are grayed out, uncheck the box that says 
Update existing field. The output field area will now be active. 

 
6. Change the Output field type to Decimal number (real). 
 
7. Set the Output field width to 10. 
 
8. Set the Output field Precision to 2. 
 
9. Click the plus sign next to Fields and Values  under Function 

List. 
 
10. Scroll down to the Population field. 
 
11. Double click the Population field.  It will appear in the Expression box. 
 
12. Type (or use the operator buttons) to add the division symbol in the Field 

calculator expression box 
 
13. Double click the Areakm2 field. 

  
 
 
 
 
 



 

MEASURE DHS and MEASURE Evaluation GIS Training 
QGIS Exercise 7: Querying Data 

110 
 

The field calculator dialog box should now look like the example below. 

 
 

14. Click OK.   
 

The new field will appear in the last column of the Attribute table. 
 

NOTE: What is the value?  What does this mean? 
 
NOTE: If you make a mistake when creating a new column or calculating the 
attribute, you may delete the unwanted column(s) by clicking the Delete 

column  button. In the Fields tab, scroll down to the field you want to 
delete and click on it so it is highlighted blue. Click to select the field you 
would like to remove from the window that appears.  Click OK. 
 
NOTE:  You must be in editing mode in order to delete columns.   

 

15. Click on Toggle editing mode  button to exit the editing session. 
 
16. When prompted, click Save. 

 
17. Close the Attribute table by clicking on the X in the upper right corner. 
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Section 7: Layer and selection summary statistics 

 
Understanding the overall summary statistics of an attribute can assist in determining 
proper categorization of the data and better understanding of the data you are using. 

 
1. Click Vector > Analysis Tools > Basic statistics. 

 

 
 

2. Select Indicators_join in the Input Vector Layer field. 
 

3. Select Pop_Dens in the Target field 
 

4. Click OK. 
 

NOTE: The window will populate with the summary statistics for the 
number of people per square kilometer in each region.  

 
5. Close the window using the X in the upper right corner.   

 
6. Exit QGIS without saving.   

 
 
Exercise End 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 8:  Adding GPS data 
 
In this exercise you will learn how to create a point vector file from a GPS data 
entered as Latitude and Longitude decimal degrees in excel. 
 
 

Section 1:  Create a CSV file in Excel 

Excel can save files in many formats including CSV files which are called a type of 
delimited files. 
 

1. Open your excel file with GPS data 
\\Training_Workshop\05_Data\01_Excel\Settlements_Cities.xls 
 

2. The file should contain a table with at least these columns: ObjectID, 
CITY_NAME, GMI_ADMIN, ADMIN_NAME, FIPS_CNTRY, CNTRY_NAME, 
STATUS, POP_RANK, POP_CLASS, Latitude, Longitude 
 

3. Open the Save as… dialog 
 

4. Navigate to \\Training_Workshop\06_Participant_Work 
 

5. Select CSV Comma Delmited (*.csv) as the Save as type. 
 

6. Name the file Settlements_Cities_ex 
 

7. Click Save. 
 

8. Click Yes in the window that appears to warn you that the file may contain 
features that are not compatible with CSV. 
 

9. Close excel (you might need to click yes several time to do this as excel will 
confirm that you want to save and close a file in a different format). 
 

Section 2: Add data to QGIS 

Using a delimited file you can add your point data to QGIS using the Delimited Text 
layer plugin. 

 
1. Start QGIS 
 
2. Select Layer > Add Delimited Text Layer or click the Add Delimited Text 

Layer on the toolbar  (See note below if you don’t see the plugin on your 
screen).  
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NOTE:  If you don’t see this tool in the menu you might need to add it.  See 
exercise 0 for details of this process.   

 
Here is the quick version: 
1. Open Manage Plugins…  
2. In the Filter box type Delimited Text Layer 
3. Check the box next to the plugin called Delimited Text Layer, this 

will add the plugin. 
4. Click Ok. 
5. Now you should see the option in the menu as described above. 

 
The Create a Layer from a Delmited Text file dialog will open 

 
3. Click the button with three periods on it  
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4. Navigate to \\ Training_Workshop\06_Participant_Work 
\Settlements_Cities_ex.csv 

 
In some cases the rest of the dialog will automatically fill itself in or QGIS might tell 
you that you need to parse the data and the fields in the window will remain blank. 

 
5. In the Layer name box TYPE: Settlements_Cities_ex 
 
6. Select the Selected Delimiter s radio button. 
 
7. Check the box next to Comma. 
 
8. Uncheck the box next to Space. 
 
9. Set the Start import at row to zero (0). 
 
10. Make sure that the X field says Longitude and the Y field Latitude 
 

The window should look like the one below. 
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11. Click Ok. 
 
The Coordinate Reference System Selector window may appear. 
 
12. Select the WGS 84 Coordinate Reference System using one of the following 

methods 
a. Scroll to the WGS 84 Coordinate Reference System located in the 

Geographic Coordinate Systems category and click on it so it is 
highlighted in blue. 

b. OR type 4326 in the Filter box and click the WGS 84 result. 
 

The window should look similar to the one below. 
 

 
 
13.  Click Ok. 

 
QGIS will automatically add the layer to your map. 

 
14. Right click on the Settlements_Cities_ex in the Layer panel and select Open 

Attribute Table. 
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15. Check the attributes of the layer by looking through the Attribute table. 
 
16. Close the Attribute table. 

 
 

 

Section 3: Save new layer as Shapefile 

When you add a delimited file to QGIS does not save the information.  You need to 
create a shapefile to save the new layer you created from your delimited file. 

 
1. Highlight the Settlements_Cities_ex layer in the Layer Panel. 
 
2.  In the layer menu select Save as…  
 
3. Make sure that the Format is set to ESRI Shapefile. 
 
4. Navigate to the \\Training_Workshop\06_Participant_Work. 
 
5. Name the file Settlements_Cities  . 
 
6. For CRS(Coordinate Reference System) make sure it is set Layer CRS, 

since you already defined WGS 84 as the CRS when you imported the GPS 
data. 

 
NOTE: Most common GPS format is WGS84 but verify this with the GPS unit 
or the data collection agency.  Often this will already be in the GPS data file. 

 
7. Check the box next to Add saved file to map to automatically add the newly 

created shapefile to your map document. 
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Your window should look like this example.  
 

 
 

8. Click Ok. 
 
9. Click Ok in the pop-up window that confirms that creation of your shapefile. 
 
10. Exit QGIS without saving. 

 
 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 8:  Adding Raster Data 
 
This exercise will teach you how to add and work with raster data in QGIS. In this 
exercise you will learn how to: 
 

•  Add a raster layer to QGIS 
• Symbolize the raster layer 
• Extract values from the raster layer  

 
You will be working with a Digital Elevation Model (DEM) in this exercise. A DEM is a 
representation of the Earth’s surface.  Each pixel of the DEM provides the elevation 
value for that particular pixel area.  Elevation values are computed from satellites 
equipped with specialized radar antennae. 
 

Section 1:  Adding and symbolizing a raster layer 

1. Start QGIS Desktop. 

2. Click the Add raster layer icon . 
 
3. Browse to //Training_Workshop/05_Data/02_Raster /DEM.tif and click Open. 
 
4. Click on the DEM layer in the Layer Panel to highlight it 
 
5. Go to the Raster menu and select Raster Colours > 1-Band Raster Colour 

Table V1.x, OR click on the 1-Band Raster Colour Table icon  from the 
toolbar. 

 
NOTE:  If you don’t see the 1-Band Raster Colour Table V1.x. plugin in the 
menu you might need to add it.  See exercise 0 for details of this process.   

 
The 1-band raster color window will allow you to customize the symbolization of 
raster layers. 

 
6. Click the drop down menu for All palettes and select DEM [topo].  This will 

select all of the color palettes that have been specially designed for 
representing elevation. 

 
7. Click the drop down menu for ***ColorBrewer Palette*** and select the color 

ramp that is green on the left, then yellow, then brown, and white on the right 
side.  Once the proper color ramp has been selected, the name 
323_DEM_screen should appear in the drop down menu. 
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8. Click the Create  button. 
 
9. Select DEM_323_DEM_screen_EG.txt from the drop down menu at the 

bottom of the window. 

 
 
10. Click Close. 

 
 
 

Section 2:  Extracting raster values to a point layer 

This section will teach you to extract the value of the raster at the exact location of a 
point and add that value to the attribute table of the point layer.  
 

1. Add the Cities_Settlements_0000 layer from 
\\Training_Workshop\05_Data\03_Shapefiles\00_Country 

 
2. Select Analyses > Point sampling tool from the Plugins menu. 
 
 NOTE:  If you don’t see the Point sampling tool in the menu you might need 

to add it.  See exercise 0 for details of this process.   
 

Here is the quick version: 
1. Open Manage Plugins…  
2. In the Filter box type Point Sampling 
3. Check the box next to the plugin called Point sampling tool, this will 

add the plugin. 
4. Click Ok 
5. Now you should see the option in the menu as described above. 

3. Select the Cities_Settlements_0000 layer from the drop down menu for Layer 
containing sampling points under the General tab. 

4. For Layers with fields/bands to get values from, select all fields that start with 
Cities_Settlements_0000 and DEM : Band 1 (raster). 

 NOTE:  You must select all the fields from the layer containing the sampling 
points for the attribute data to from the original layer to be included in the 
new layer that will contain the extracted raster values. 

5. For Output vector layer, browse to \\Training_Workshop\06_Participant_Work 
and name the file Cities_wElevation.shp 

6. Check the box next to Add created layer to the TOC. 
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Your Point Sampling Tool window should now similar to this. 

 

7. Click OK. 

8. Close the Point Sampling Tool window. 

9. Right click on the layer Cities_wElevation in the layer panel and select Open 
attribute table. 

10. Scroll to the last field in the attribute table called DEM that contains the 
elevation (in meters) for each point location in the file. 

 
 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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QGIS Exercise 10:  Adding basemaps 
 
This exercise will teach you how to add aerial imagery to QGIS. When making a 
map, it is sometimes easier to use a pre-made base map.  Depending on the map, 
you may use aerial imagery (with or without labels), a street map, or a hybrid of the 
two.  In this exercise you will learn how to add aerial imagery base maps from Bing 
and open street maps. 
 

Section 1:  Adding vector data and a basemap 

1. Open QGIS Desktop. 
 
2. Add the DHS_Regions layer from 

\\Training_Workshop\06_Data\03_Shapefiles\00_Country 
 
3. Select Plugins > OpenLayers plugin > Add Bing Aerial layer with labels from 

the Plugins menu. 
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NOTE:  If you don’t see the OpenLayers plugin in the menu you might need 
to add it.  See exercise 0 for details of this process.   

 
Here is the quick version: 

1. Open Manage Plugins…  
2. In the Filter box type OpenLayers 
3. Check the box next to the plugin called OpenLayers plugin, this 

will add the plugin. 
4. Click Ok 
5. Now you should see the option in the menu as described above. 

The imagery may take a minute or two to load.   

4. Once it has loaded left-click the Bing Aerial layer in the layer panel (also 
called table of contents) and hold the mouse button down while dragging the 
layer below the DHS_Regions layer. 

You should now see the regions of the country over the aerial image. 

 NOTE:  If you don’t see the DHS_Regions layer, go to the Layers Panel (also 
known as the Table of Contents), left-click on the DHS_Regions layer and 
drag it to the top of the layer panel while holding the mouse button down. 

5. Right click on the DHS_Regions layer and select properties. 

6. Click the Style tab. 

7. Click the Change button on the left  

8. Select No Brush for the Fill style. 

9. Select the color white for the Border color. 

10. Click OK. 

11. In the Layer properties window, adjust the Transparency slide to the right 
until the number says 50%. 

  

12. Click OK. 

13. Zoom into regions at different levels and pan the map to explore the aerial 
imagery.  
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Section 2:  Changing the basemap 
1. Uncheck the box next to Bing Aerial with labels in the Layer Panel. 
 
2. Select Plugins > OpenLayers plugin > Add OpenStreetMap layer from the 

Plugins menu. 

3. Right click on the DHS_Regions layer and select properties. 

4. Click the Style tab. 

5. Click the Change button on the left  

6. Click the Change button for the Border color. 

7. Select a dark gray color from the spectrum by clicking and adjusting the 
color. 

 

8. Click OK. 

9. Click OK. 

10. Click OK. 

11. If the DHS_Regions layer is not the first in the layer panel, then left-click on 
the layer and drag it to the top of the layer panel while holding the mouse 
button down. 

12. Zoom into regions at different levels and pan the map to explore. 
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Do you notice any differences between the DHS_Regions layer and the basemaps? 
 
 

 

In which cases do you think basemaps are useful? 

 
 
 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Supplemental QGIS Exercise:  Buffering and Intersecting Data 
 
In this exercise you will learn how to identify points that fall within a certain distance 
of a feature.  This exercise will use the example of determining which towns are 
located close to a permanent/perennial river or lake.  You will learn to buffer a 
shapefile using a specified distance, then perform an intersect of the buffered layer 
and the towns layer to determine which towns fall within the specified distance.  
 
 
 

Section 1:  Adding and re-projecting layers 

The Inland_Water shapfile is in the WGS 84 coordinate reference system, for which 
the units are decimal degrees.  In order to buffer the layer using a distance in 
meters, the layer must be reprojected into a projected coordinate system with meters 
for units. 
 

1. Open QGIS. 
 
2. Add the vector layer Inland_Water from the data folder 

\\Training_Workshop\06_Data\03_Shapefiles\00_Country\Inland_Water.shp. 
 
3. Right click on the Inland_Water layer and select Save as... 
 
4. Select ERSI Shapefile for Format. 
 
5. For Save as, browse to \\Training_Workshop\06_Participant_Work\ and type 

Inland_Water_UTMproject.shp for the file name. 
 
6. Select Selected CRS from the CRS drop down menu. 
 

 
 
7. Click the Browse button to select the CRS. 
 
8. Type 32737 into the Filter field of the Coordinate Reference System Selector. 
 
9. Select WGS 84 / UTM zone 37S. 
 
10. Click OK. 
 
11. Check the box next to Add saved file to map. 
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Your window should now look like this. 

 
 

12. Click OK in the Save vector layer as… window. 
 
13. Go to the Settings menu and select Project Properties. 
 
14. Check the box next to Enable ‘on the fly’ CRS transformation. 

 
 
15. Click OK. 
 
16. Turn off the original Inland_Water layer by un-checking the box next to it. 
 

17. Click the Zoom full button . 
 
 

Section 2:  Creating a buffer 

You only want to buffer Perennial or Permanent water sources, so you must select 
them from the layer. 
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1. Right click the Inland_Water_UTMproject layer and select Open attribute 

table. 
 
2. Click the Advanced search button on near the bottom right corner of the 

table. 
 
3. In the Search query builder window, double click the HYC_DESCRI field so it 

appears in the SQL where clause box. 
 
4. In the values box, click the All button. 
 
5. Click the equals sign in the Operators box. 
 
6. Double click the ‘Perennial/Permanent’  text within the Values box.  

 
Your Search query builder  window should now look like this: 
 

 
 

7. Click OK. 
 

All of the permanent river and lakes should now be highlighted. 
 
8. Close the attribute table. 
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9. In the Vector menu, select Geoprocessing Tools > Buffer(s). 
 
10. In the Buffer(s) window, choose Inland_Water_UTMproject for the Input 

vector layer. 
 
11. Check the box for Use only selected features.  
 
 NOTE: Using only selected features will apply the buffer to only the selected 

Perennial/Permanent inland water, rather than the entire layer. 
 
12.  Select the radio button for Buffer distance and enter 2000 into the box.  The 

units for the layer are in meters, so this is equal to 2 kilometers. 
 
13. Check the box for Dissolve buffer results. 
 
 NOTE: Dissolving buffer results will merge all the individual buffers of each 

river and lake into one single buffer. 
 
14.  Browse to \\Training_Workshop\05_Exercises\Project_files\ and name the 

file P_Water_2km_BufferUTM. 
 
Your Buffer(s) window should look like this example. 
 

 
 
15. Click OK. 
 
 NOTE: The buffer tool make take several minutes to run.  Do not click the 

Cancel button while the tool is running. 
 
16.  When the tool is done running, you will receive a prompt asking if you want 

to add the new layer to the TOC.  Click Yes. 
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17. Close the Buffer(s) window. 
 

Section 3:  Re-projecting the buffer layer 

Now that the buffer is complete, you must re-project your buffer layer into the WGS 
84 coordinate reference system so that it matches the decimal degree units and 
coordinate reference system of the Settlements layer for the intersect. 
 

1. Right click on the P_Water_2km_BufferUTM layer and select Save as... 
 
2. Select ERSI Shapefile for Format. 
 
3. For Save as, browse to \\Training_Workshop\06_Participant_Work\ and type 

P_Water_2km_Buffer for the file name. 
 
4. Select Selected CRS from the CRS drop down menu. 
 

 
 
5. Click the Browse button to select the CRS. 
 
6. Type 4326 into the Filter field of the Coordinate Reference System Selector. 
 
7. Make sure the filter selected WGS 84. 
 
8. Click OK. 
 
9. Check the box next to Add saved file to map. 
 
10. Click OK in the Save vector layer as… window. 

 

Section 4:  Creating an intersect 

1. Add the vector layer glpv1 located at 
\\Training_Workshop\06_Data\03_Shapefiles\01_World\gl_grumpv1_ppoints_
shp\glpv1.shp 
 

2. In the Vector menu, select Geoprocessing Tools > Intersect. 
 

3. In the Intersect window, select glpv1 as the Input vector layer. 
 

4. Select P_Water_2km_Buffer  as the Intersect layer. 
 

5. Browse to \\Training_Workshop\06_Participant_Work\ and name the file 
Towns_in_2km_WatBuff.shp 
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Your Intersect window should look like this example. 

 

 
 

6. Click OK. 
 
NOTE: The intersect tool may take several minutes to run.  Do not click the 
Cancel button while the tool is running. 
 

7.  When the tool is done running, you will receive a prompt asking if you want to 
add the new layer to the TOC.  Click Yes. 
 

8. Close the Intersect window. 
 

9. Right click on the Towns_in_2km_WatBuff layer and select Zoom to layer 
extent. 
 

The Towns_in_2km_WatBuff layer should display only the towns that are within 2 
kilometers of a perennial or permanent river or lake. 

 
Why is this information important, and how could it be used? 
 
 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Supplemental QGIS Exercise:  Exploring Spatial Data 
 
This exercise will introduce you to how to view the information and specifications 
about spatial data and how to download spatial data from the internet.  In this 
exercise you will learn how to: 
 

• Preview spatial data in QGIS Browser 
• View metadata for a shapefile in an internet browser 
• Download a shapefile from the internet 
• Import the downloaded file to QGIS 
• View metatada for a shapefile in QGIS 

 
 

Section 1:  Previewing spatial data in QGIS Browser 

It is helpful to quickly glance at a preview of a shapefile or raster and its attributes 
without having to add it to a map document.  QGIS Browser allows you to do so, and 
then directly drag and drop layers directly into QGIS Desktop. 
 

1. Click Start > Programs > Quantum GIS Lisboa > Quantum GIS Browser 
(1.8.0). 

 
 
2. Browse to 

\\Training_Workshop\05_Data\03_Shapefiles\01_World\Admin0_Polygons_S
SIB.shp using the file tree on the left side of the Browser 
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3. Read through the information in the Metadata tab for the 
Admin0_Polygons_SSIB shapefile. 

 
4. Click on the Preview tab to view a sample of the layer. 
 
5. Click on the Attributes tab to view a preview of the attribute table for the 

layer. 
 

Now you will add Admin0_Polygons_SSIB shapefile to a map document from the 
QGIS Browser. 

 
6. Click Start > Programs > Quantum GIS Lisboa > Quantum GIS Desktop 

(1.8.0). 
 
7. Navigate back to the Admin0_Polygons_SSIB shapefile in QGIS Browser. 
 
8. Left-click on the layer and hold down the mouse button. 
 
9. Drag the layer from the QGIS Browser to the Layer Panel within your QGIS 

Desktop window. 
 

 
 
10.  Release the mouse button. 
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NOTE: The Admin0_Polygons_SSIB shapefile should now appear in your 
QGIS Desktop window.  It will also still appear in the QGIS Browser window.  
Dragging a layer from the Browser to the Desktop window does not change 
the storage location of the shapefile, it simply adds the layer to a map 
document. 

 
11. Close QGIS Desktop. 

 

Section 2:  Viewing metadata in an internet browser 

Sometimes you would like to analyze or make a map for which you do not have all 
the necessary information.  The internet is a good source for spatial data, but you 
must make sure you explore the information about files to make sure they contain 
the data you need, and so you know how to properly display them in QGIS. 
 

1. Open your internet browser and navigate 
to http://sedac.ciesin.columbia.edu/data/set/grump-v1-settlement-points 
 

2. Click on the Metadata tab.   
 

 
 
You should see the information for the following sections: 

a. Identification 
b. Data Quality 
c. Spatial Data Organization 
d. Spatial Reference 
e. Entity and Attribute 
f. Distribution 
g. Metadata Reference 

 
3. Read the key pieces of information 

a. Identification Information > Citation > Citation Information 
b. Identification Information > Description > Abstract 
c. Identification Information > Description > Purpose 
d. Identification Information > Use Constraints 
e. Spatial Data Organization Information > Direct Spatial Reference 

Method 
f. Spatial Reference Information > Horizontal Coordinate System 

Definition > Geodetic Model > Horizontal Datum Name 
 

Section 3:  Downloading a shapefile from the internet 

1. Navigate back to http://sedac.ciesin.columbia.edu/data/set/grump-v1-
settlement-points 
 

2. Click on the Data Download tab. 
 

http://sedac.ciesin.columbia.edu/data/set/grump-v1-settlement-points�
http://sedac.ciesin.columbia.edu/data/set/grump-v1-settlement-points�
http://sedac.ciesin.columbia.edu/data/set/grump-v1-settlement-points�
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3. Select Settlement Points from the Data Set dropdown menu. 
 

4. Select .shp from the Data Attributes dropdown menu. 
 

5. Select circa 2000 from the Data Attributes dropdown menu. 
 
Your window should look like this image. 
 

 
 

6. Click Download. 
 

7. You will be taken to a login screen.  You may either register, or click the 
Guest Downloads button under the login box. 
 

 
 
The file will begin downloading to the default location on your computer.   
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Section 4:  Importing downloaded data to QGIS 

1. Go to the downloads folder located at C:\Users\username\Downloads and 
locate the file called gl_grumpv1_ppoints_shp.zip 

 
2. Right click on the file and select Extract All… 
 
3. Browse to \\Training_Workshop\06_Participant_Work 
 
4.  Click Extract. 
 
5. If the folder does not automatically open with the extracted shapefile, 

navigate to 
\\Training_Workshop\06_Participant_Work\gl_grumpv1_ppoints_shp and 
open the document called readme.txt 

 
ReadMe files are sometimes included when you download a shapefile, and contain 
helpful information that explains the data and the fields in the attribute table. 

 
6. Read through the readme.txt file. 
 
7. Open QGIS Deskstop. 

8. Click the Add Vector Layer button . 
 
9. Browse to 

\\Training_Workshop\06_Participant_Work\gl_grumpv1_ppoints_shp  
 
10. Click Open. 

 
Your QGIS window should look similar to this image. 
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Section 5:  Viewing metadata in QGIS 

1. Select Metatools > View metadata from the Plugins menu. 
 

 
 
NOTE:  If you don’t see this plugin in the menu you might need to add it.  See 
exercise 0 for details of this process.   

  
Here is the quick version: 

1. Open Manage Plugins…  
2. In the Filter box type Metatools 
3. Check the box next to the plugin called Metatools, this will add the 

plugin. 
4. Click Ok 
5. Now you should see the option in the menu as described above. 
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2. In the Metadata viewer window, explore the information in the tabs along the 
top as well as the sections under each tab. 
 

 
 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Supplemental QGIS Exercise:  Creating Metadata 
 
This exercise will teach you how to create metadata in QGIS.  In this exercise you 
will learn how to: 
 

• Set a metadata standard 
• Create and apply metadata templates 
• Create metadata for a file 
• View the metadata you created 

 

Section 1:  Set a metadata standard in QGIS 

1. Open QGIS. 
 

2. Add the vector layer 
\\Training_Workshop\05_Data\03_Shapefiles\00_Country\Indicators_join.shp 
 

3. Right-click on the Indicators_join layer in the Layer Panel and select Zoom to 
layer extent. 
 

4. In the Plugins menu, select Metatools > Configure Metatools plugin 
 

5. Choose csir_sac_profile.xml from the drop down menu under the Default 
profile in the Metatools settings window > General tab. 
 
NOTE: There are many styles of metadata.  The international standard and 
most widely used format is known as ISO 19115.  The profile 
csir_sac_profile.xml follows the ISO 19115 standard. 
 

 
 

6. Click OK. 
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Section 2:  Create and apply metadata templates in QGIS 

Creating template information to apply to your metadata can save time since you 
only need to input some information once, and it can be applied to files in the future.  
For example, you may enter the institution and contact information once, and then 
apply it to all the layers you create while employed at that institution. 

 
1. In the Plugins menu, select Metatools > Apply templates 
 
2. Click the Manage button for the Institution in the Templates section. 
 

 
 
3. Enter the appropriate information for your organization in the Manage 

organizations window that appears. 
 
On the next page is an example of the information for ICF International. 
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4. Click Save once you have entered the information. 
 
5. Click Close. 
 
6. Select your organization name from the drop down menu next to Institution in 

the Apply templates window. 
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7. Check the boxes next to the options Extract layer parameters to metadata 
XML and Generate preview image. 

 
NOTE: Enabling the extraction of layer parameters to metadata xml will auto 
populate the metadata with certain layer specifications such as the data type 
and the spatial extent. 

 
8. Click on the Indicators_join layer to select it. 
 
9. Click the Apply button.  
 
10. Click the Close button. 

 
 

Section 3:  Create metadata in QGIS 

1. Select Metatools > Edit metadata from the Plugins menu. 
 

A window may appear warning you that the layer does not have metadata, and will 
ask if you want to create metadata. 

 

 
 
2. Click Yes. 
 
3. In the Metadata editor window, click on the plus sign to the left of the 

MD_Metadata under the Name column. 
 
4. Click on the plus sign next to fileIdentifier 
 
5.  Click on the gco:CharacterString so that it is highlighted blue. 
 

Within the Edit value window, it should say MD_Metadata -> fileIdentifier -> 
gco:CharacterString. 

 
6.  In the text box of the Edit value window, type an appropriate file identifier.  

For example: CountryName_Regional_Indicators. 
 
7. Click the Apply button and the text you just typed will appear under the value 

column in the Full view tab 
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8. Click on the plus sign next to the identificationInfo field. 
 
9. Click on the field MD_DataIdentification field that appears below. 
 
10. Click the plus signs within the MD_DataIdentification field, until you reach the 

gco:CharacterSring level.   
 
11. Fill in the appropriate information in the Edit Value section on the right for 

each field, making sure to click Apply after you enter the information for each 
field.  

 
NOTE: Ignore the extent field, which was already auto populated when you 
applied the template in Section 2. 
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Your window should look similar to the example below, but with your country’s 
information in the value column. 
 

 
 

12.  Click the Save button. 
 
13. Repeat steps 10 and 11 for the dateStamp field. 
 
14. When you have entered and saved the information, click Close. 
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Section 4:  View metadata in QGIS 

 
1. Go to the Plugins menu and select Metatools > View metadata  to view the 

information you just entered. 
 

The metadata view window should look similar to this, but with your information. 
 

 
 
 
 
EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Supplemental QGIS Exercise:  Advanced Labeling 
 
This exercise will teach you how to add complex labels to your map documents.  In 
this exercise you will learn how to: 
 

•    Create a new multi-line label field 
•    Label your map with the new label field 
•    Manipulate the placement of your labels 

 

Section 1:  Creating a new multi-line label field 

This section will show you how to create a label for each region that contains the 
region name, the percentage of females age 15-49 with no education, and the 
percentage of males age 15-49 with no education. 

 
1. Open QGIS. 
 
2. Add the vector layer Indicators_join.shp located in 

\\Training_Workshop\05_Data\03_Shapefiles\00_Country 
 
3. Right click on the Indicators_join layer and select Open Attribute Table. 
 
4. Click the  Toggle editing mode button  OR type CTRL+E. 
 
5. Click the  Open field calculator  button  OR type CTRL+I. 
 
6. Enter Label for Output field name. 
 
7. Change the dropdown menu to Text (string) for Output field type. 
 
8. Change the Output field width to 50. 
 
9. Click the plus sign next to the Fields and Values under the Function List. 

 
 
10. Duble click the DHSREGEN field under the Fields and Values heading to 

insert it in the Expression box. 
 

11. Click on the  button from the Operators.   
 

NOTE: The   operator combines multiple fields.   
 
12.  Type '\nWomen: ' 
 

NOTE: Make sure to type a space between the colon and the apostrophe.   
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NOTE: The  ‘\n’ indicates a new line for the label.  You may insert it wherever 
you would like a line break.   

 

13. Click on the  button.   
 
14. Double click F_NOEDUCAT in the Fields menu. 
 

15.  Click on the  button and type another space. 
 
16.  Type '%'. 
 

17. Click on the  button from the Operators.   
 
18. Type '\nMen: ' 
 

NOTE: Make sure to type a space between the colon and the apostrophe.   
 

19. Click on the  button.   
 
20. Double click M_NOEDUCAT in the Fields menu. 
 

21.  Click on the  button. 
 
22. Type '%' 
 
23.  Check your entire field calculator expression to make sure it now reads:  

DHSREGEN || '\nWomen: ' || F_NOEDUCAT || '%' || '\nMen: ' || 
M_NOEDUCAT || '%' 
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This is an example of what your field calculator window should look like. 
 

 
 

24.  Click OK. 
 
25. If you receive an error message, check your Field calculator expression to 

make sure it is the same as in the above example.  You may also try cutting 
and pasting the expression from step 23 into your field calculator expression 
window. 

 
26. Open the attribute table for the Indicators_join layer and scroll to your newly 

created Label field.  It should contain the region name on line one, followed 
by the percent of women with no education on the second line, and then the 
percentage of men with no education on line three. 

 
27. Click on the  Toggle editing mode button to exit the editing mode. 
 
28. Click Save when the message appears asking if your want to save your 

edits.   
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Section 2:  Label your map with multi-line field 

Now that your labeling field has been generated, it is time to use it to label your map. 
 

1. Go to the layer menu and select . 
 

2.  Check the box next to Label this layer in the Layer labeling settings window. 
 

3. Select the field called Label from the Label this layer with drop-down menu. 

 
 

4. Click on the button with three dots in the Text Style section of the Label 
Settings tab. 

 
 

5. Set the Font style to Bold. 
 

6. Click OK. 
 

7. Click OK. 
 
 
 
 

Section 3:  Edit the placement of labels 

For most maps, it is necessary to adjust the automatic placement of labels so they fit 
better with the features they are labeling.   

 
1. Go to the layer menu and select  Toggle editing. 
 

NOTE: To edit label placement in QGIS, you must be in editing mode. 
 
2. Open the attribute table for the Indicators_join layer. 
 
3. Click the  New column button. 
 
4. In the add column window, name the column X. 
 
5. For the Type, select Decimal number (real). 
 
6. Set the Width to 8 and the Precision to 5. 
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Your Add column window should now look like this. 
 

 
 
7. Click OK. 
 
8. Click the  New column button. 
 
9. In the add column window, name the column Y. 
 
10. For the Type, select Decimal number (real). 
 
11. Set the Width to 8 and the Precision to 5. 
 
12. Click OK. 
 
13. Go to the layer menu and select . 
 
14. Click on the Data defined settings tab. 
 
15. Scroll down to the Position box.   
 
16. Choose the X field you just created from the drop down menu for the X 

Coordinate. 
 
17. Choose the Y field you just created from the drop down menu for the Y 

Coordinate. 
 

NOTE: To edit label placement in QGIS, you must create new X and Y 
columns within the attribute table.  The labeling plugin will automatically 
update the columns with the coordinates of the position where you decide to 
place your labels. 
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18. Click OK. 
 

19. Click the  Move label button in the Label toolbar. 
 

NOTE: If you don’t see the label toolbar, right click on an empty portion of 
your menu bar and check the box next to Label. 

 
20. Move the cross hairs and hover over a label you wish to move. 
 
21. Left-click and hold the button down.  A green box will appear around the 

label. 
 
22. Drag the label to where you would like it to be and then release the mouse 

button. 
 

NOTE: If you are unable to move your labels, check to make sure that the 
layer alias does not contain any special characters such as “à , é, ë.. etc.”  If 
it does, rename your layer without special characters. 

 
23. Repeat steps 20 - 22 with the label for each region until you are satisfied with 

all the label placements. 
 



 

MEASURE DHS and MEASURE Evaluation GIS Training 
Supplemental QGIS Exercise: Advanced Labeling 

162 
 

24. Go to the layer menu and select . 
 
25. Go to the layer menu and select  Toggle editing to exit editing mode. 
 
26. Pan around your map.  Do the labels move with the regions? 

 
 

 
 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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Supplemental Exercise:  Working with Google Earth 
 
In this exercise you will begin by exploring the fundamentals of Google Earth.  You 
will navigate the globe.  In addition to learning how to save and print screen shots, 
you will learn how to create, edit, and share your own KML files, which are a type of 
text-based spatial data file which can be used by other mapping programs.  

Section 1: Download Google Earth 

1. Google Earth is available as a free download 
at http://www.google.com/earth/. 

 
NOTE: This exercise was created using version 6.2 of Google Earth.  Icons 
and menus may be different in other versions. 

 

2. Click the download button.  
 
3. Once the download is complete, install using the *.exe file. 

 

Section 2: Open Google Earth and practice navigation 

1. Double-click the icon for Google Earth on your screen.  You should see the 
main view screen and menus:  

 
 

2. Click and drag anywhere on the globe to rotate the globe’s viewing area.    
To zoom in to a particular position, either double-click on it, or enter its name 
or its coordinates into the Search box, highlighted above (upper left).   

http://www.google.com/earth/�
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3. Practice using the Navigation controls (also highlighted above, upper right) 

to zoom in and out and change position. 
 
 NOTE: To orient the viewing area at any time so that North is 

toward the top of the screen and the viewing angle is straight 
downward, click the letter “R” on your keyboard or by clicking the 
“N” at the top of the navigation controls.     

 
4. Turn the navigation controls on and off by choosing from the top menu  

View>Show Navigation>Always (or Automatic or Never).     
 
5. Expand or collapse the Sidebar boxes on the left by clicking on the little 

triangles to the left of each of them: Search, Places, and Layers.   
 
6. To fill the screen with the main view, click on the show/hide sidebar toggle 

button as highlighted blue below: 
 

 
 
7. Turn on and off the streaming content available from Google Earth’s Primary 

Database by clicking in the boxes to the left of the descriptions in the Layers 
sidebar.  Clicking the “   ” sign will expand each layer into its sub-layers for 
more viewing control.  (In the view above, only Borders and Labels has been 
displayed, as indicated by the yellow country borders in the viewing 
window.) 
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8. Zoom to your capital city by entering its name in the Search sidebar.   
 
9. Examine historical satellite imagery by clicking on the “clock” icon along the 

top command bar (see below).  Click on the bar which appears to select 
imagery from different dates.  Do you see any changes over the course of 
time?  Notice that some images taken at different times of the year or with 
different satellites may have variations in color, clarity and even cloud cover. 

 

 
 
10. Close Google Earth to complete this portion of the tutorial. 

 

Section 3: Opening a KMZ file in Google Earth 

You are now ready to begin opening and creating KMZ files, a map file format which 
can be read by Google Earth and displayed on top of its imagery.  KMZ files can 
contain lines, polygons, and points.  KMZ is a compressed form of a KML file.  A 
KML file can be read by Google Earth and some other GIS programs, and can also 
be edited in an XML editor.   
 

NOTE:  KML/KMZ files use longitude and latitude (and, optionally, altitude) 
coordinates as defined by the World Geodetic System of 1984 (WGS 84).  
When using any mapping program or GPS unit it is important to note the 
coordinate system in use by any given map.  Some GIS systems can read 
and convert dozens of different coordinate systems.  It can be tricky to convert 
data accurately from one coordinate system to another.   Points collected in a 
coordinate system other than WGS 84 will not necessarily line up with the 
imagery in Google Earth. 
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1. Browse to the file Site_tour.kmz at 
\\Training_Workshop\05_Data\03_Shapefiles\01_World on your computer and 
double-click its icon to open the file in Google Earth.   

 
 

2. Your file will appear in the Places sidebar under “Temporary Places”.   
 

3. Click on the “   ” sign to display the list of the 3 point locations that are 
contained in the file.  The globe image will also rotate and zoom automatically 
to include a view of everything contained in this file.  The 3 points (displayed 
as yellow “pushpins”) have been circled above in red—zoom into each of 
them for a closer look using the navigator controls in the upper right.  In the 
Layers sidebar, choose to display the “borders and labels” database layer for 
added visual reference by clicking the box to the left of its name.  The borders 
are showing up here in yellow. 

 
NOTE:  If you wish to save the KMZ file to “My Places”, Google Earth will then 
find and open this file each time you open Google Earth.  If not, you will need 
to locate it on your own to open it.  You will be asked, each time you close 
Google Earth, whether you would like to save the files in your Temporary 
Places folder in this manner.  Not saving a KMZ file to My Places does not 
delete the file from your computer; it simply means you will need to find it on 
your own next time. 

 
 

Section 4: Creating a KMZ file in Google Earth 

1. Using the navigation controls, zoom into your home city and visually locate 5 
places of interest (for example, hospitals, health facilities, schools, etc.).   
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2. Zoom into the first one and choose Add>Placemark, or simply click on the 

appropriate button as circled in red below.   

 
 

3. A new marker will be placed in the middle of the current view screen and a 
Google Earth – New Placemark window will open   
 

4. In the Name box, enter the name of the placemark. 
 

You will note that the latitude and longitude of the location you have chosen will 
appear in the dialog box as well.  If you edit these, the marker will move to the new 
corresponding location.   

 
5. In the Description tab, enter the name and description for the feature you 

have selected.  This description will appear in a pop-up bubble whenever you 
left-click on the point in the future. 
 

Your Google Earth – New Placemark window should look like this, but with the 
information of your placemark. 
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6. Choose OK to save the information.  To save this point in a KML or KMZ file, 

right-click on it to see a pop-up menu, as below: 
 

 
 
7. Now choose Save Place As . . . and browse to 

\\Training_Workshop\06_Participant_Work and name the file according to the 
title of the landmark. 

8.  
NOTE:  A further option under Save as type would be KML, which is simply 
an uncompressed and more easily editable version of a KMZ file. 

 
9. After you have saved the placemark, close Google Earth. 

 
 
 

Section 5: Adding new placemarks to existing KMZ files 

Next you will look at other points of interest in your home city.   
 

1. Browse to \\Training_Workshop\06_Participant_Work and open the file 
placemark KMZ file that you just saved. 
 

2. Say we want to save other locations of interest as other points within the 
same KMZ file.  Locate and zoom to a second landmark within your city.   
 

3. Select the KMZ landmark file that you created in the Places menu so that it is 
highlighted blue.  This will ensure the next placemark you add will be added to 
the same file. 
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4. Click the Add placemark button  (or choose it from the Add menu) and 
enter its information into the dialog box, then choose OK.  You should see 
something like the view below: 

  
 
There are now 2 points within the landmark name KMZ file you created.   
 

5. Your original file name is no longer appropriate, as it now contains another 
location, so right-click its name and choose Rename from the pop-up menu.  
Type in the name of the city followed by the word Landmarks as a new KMZ 
file name.   
 

6. Then right-click again and choose Save Place As..., browse to 
\\Training_Workshop\06_Participant_Work, make sure the file has your 
updated file name, and click Save to make sure all locations are now saved in 
the same KMZ file. 

 

Section 6:  Visually re-positioning or otherwise editing a placemark 

1. Click the Add placemark button  drag it to a random location in your 
Google Earth window, and click OK. 

 
Now you need to move the placemark to the third landmark in your city. To edit the 
location of a placemark, you have two choices:    
 

2. Right-click on the placemark, choose Properties from the pop-up menu, and 
type in new lat/long coordinates, or  
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3. Right-click on the placemark, choose properties, and observe that the 
placemark how has a flashing, highlighted “bull’s eye” box around it (if 
necessary, move the Edit Placemark dialog box out of the way by dragging its 
title bar).  While the placemark is highlighted in this manner, you can click on 
it and drag it to a new position on the background image.   

 
 

4. While the Properties dialog is open, edit the description and name of the point 
to match the landmark.   

 
5. Choose OK.  

 
6. No matter which method you have used to move the placemark, you need to 

right-click on the KMZ file name in the Places sidebar and choose Save As... 
to replace the old file with the new one.   

 
7. Browse to \\Training_Workshop\06_Participant_Work and keep the same 

name (which will result in an alert message telling you it already exists and 
you are replacing the original—choose “Yes” to do so.) 

 
NOTE: If you do not re-save your KMZ file after making edits or adding points, 
(or, alternatively, do not save any of your new points to “My Places”), then 
your information will be lost upon exiting Google Earth. 
 
NOTE:  When you chose Add Placemark, make sure to note where the new 
point is being entered.  In the illustration below, 3rd Landmark was added to 
the Temporary Places folder and not to Lankmark_Name.KMZ (note the 
dotted line to the left of the names in the sidebar).   
 

 
 

If you wanted this point to be part of the hospitals file, you could click on its name 
and drag it onto the name of your Landmark KMZ file.  (See the result on the next 
page). 
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NOTE: If you right click on any of the names of the files in the Places sidebar 
and choose “Delete”, you are not deleting the actual file.  You are simply 
removing it from the Temporary Places (or My Places) location.  This 
procedure is unique to Google Earth and may take some getting used to; you 
may want to try it for yourself until you feel comfortable manipulating your map 
files within the Places sidebar. 

 
 
 

Section 7:  Saving an image of the map for printing or sharing 

In addition to saving your point file as a KML or KMZ, you may also want to save the 
background image as it displays in the Google Earth viewing window.   
 

1. Choose File>Save>Save image… 
 

 
 

2. Enter a file name in the dialog box which appears and save it in 
\\Training_Workshop\06_Participant_Work.  This will save a JPG (photograph 
format) file to the indicated folder.   
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3. Navigate to your file and click on it to view the image.   

 
This image can be printed or sent to others for viewing.  Unlike the KML/KMZ file, 
this image will not require Google Earth to be installed on the recipient’s machine in 
order for them to open it. 
 

NOTE:   It is important to note that if you wish to manipulate your locations 
from within another mapping program, such as ArcGIS or QGIS, you will need 
the KML file.   The JPG is simply a screenshot image and does not contain 
location data and is not tied in any way to the surface of the earth. 
 
 

EXERCISE END 
 
MEASURE DHS and MEASURE Evaluation are funded by the U.S. Agency for 
International Development (USAID). The information provided in this exercise is not 
official U.S. government information and does not necessarily represent the views of 
USAID or the U.S. government. 
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